summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqsh/sqsh-2.1-r1.ebuild')
-rw-r--r--dev-db/sqsh/sqsh-2.1-r1.ebuild38
1 files changed, 16 insertions, 22 deletions
diff --git a/dev-db/sqsh/sqsh-2.1-r1.ebuild b/dev-db/sqsh/sqsh-2.1-r1.ebuild
index acad1aaa14c2..884aa0a0052e 100644
--- a/dev-db/sqsh/sqsh-2.1-r1.ebuild
+++ b/dev-db/sqsh/sqsh-2.1-r1.ebuild
@@ -1,42 +1,36 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/sqsh-2.1-r1.ebuild,v 1.8 2005/01/01 17:43:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/sqsh-2.1-r1.ebuild,v 1.9 2005/04/06 20:48:47 seemant Exp $
+
+inherit eutils
DESCRIPTION="Replacement for the venerable 'isql' program supplied by Sybase."
HOMEPAGE="http://www.sqsh.org/"
+SRC_URI="http://www.sqsh.org/${P}-src.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+IUSE="readline X motif"
+KEYWORDS="x86 ~amd64"
+
DEPEND="dev-db/freetds
readline? ( sys-libs/readline )
X? ( virtual/x11 )
motif? ( x11-libs/openmotif )
virtual/libc"
-SLOT="0"
-SRC_URI="http://www.sqsh.org/${P}-src.tar.gz"
-KEYWORDS="x86 ~amd64"
-IUSE="readline X motif"
src_compile() {
export SYBASE=/usr
local myconf
- use readline \
- && myconf="${myconf} --with-readline"
-
- use X \
- && myconf="${myconf} --with-x"
-
- use motif \
- && myconf="${myconf} --with-motif"
-
- ./configure \
- ${myconf} \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ use motif && myconf="--with-motif"
+
+ econf \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die
- patch src/config.h ${FILESDIR}/config.patch
emake SQSHRC_GLOBAL=/etc/sqshrc || die
}
@@ -50,7 +44,7 @@ src_install () {
infodir=${D}/usr/share/info \
install install.man || die
# fix the silly placement of sqshrc
- mkdir -p ${D}/etc
+ dodir /etc
mv ${D}/usr/etc/sqshrc ${D}/etc/
rmdir ${D}/usr/etc
dodoc COPYING INSTALL README doc/*