summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/uudeview/uudeview-0.5.18.ebuild')
-rw-r--r--app-text/uudeview/uudeview-0.5.18.ebuild42
1 files changed, 15 insertions, 27 deletions
diff --git a/app-text/uudeview/uudeview-0.5.18.ebuild b/app-text/uudeview/uudeview-0.5.18.ebuild
index 1262237ea40e..c0378baf54ca 100644
--- a/app-text/uudeview/uudeview-0.5.18.ebuild
+++ b/app-text/uudeview/uudeview-0.5.18.ebuild
@@ -1,40 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/uudeview/uudeview-0.5.18.ebuild,v 1.6 2003/02/13 09:47:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/uudeview/uudeview-0.5.18.ebuild,v 1.7 2003/08/01 20:48:14 vapier Exp $
-IUSE="tcltk"
-
-S="${WORKDIR}/${P}"
DESCRIPTION="uu, xx, base64, binhex decoder"
-
-SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${P}.tar.gz"
HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
-KEYWORDS="x86 ~sparc"
-SLOT="0"
-LICENSE="GPL-2"
-DEPEND="tcltk? ( dev-lang/tcl dev-lang/tk )"
+SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${P}.tar.gz"
-src_compile() {
- local myconf
- use tcltk || myconf="--disable-tcl --disable-tk"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE="tcltk debug"
- [ -n "${DEBUGBUILD}" ] && myconf="${myconf} --disable-optimize"
+DEPEND="tcltk? ( dev-lang/tcl dev-lang/tk )"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- ${myconf} \
- --mandir=${D}/usr/share/man || die "./configure failed"
+src_compile() {
+ econf \
+ `use_enable tcltk tcl` \
+ `use_enable tcltk tk` \
+ `use_enable debug optimize` \
+ || die
make || die
}
-src_install () {
- make \
- prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- install || die
-
- # Install documentation.
+src_install() {
+ einstall MANDIR=${D}/usr/share/man/ || die
dodoc COPYING INSTALL README
}