summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/kbibtex/kbibtex-0.4.ebuild')
-rw-r--r--app-text/kbibtex/kbibtex-0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/kbibtex/kbibtex-0.4.ebuild b/app-text/kbibtex/kbibtex-0.4.ebuild
new file mode 100644
index 000000000000..911c18629f41
--- /dev/null
+++ b/app-text/kbibtex/kbibtex-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.4.ebuild,v 1.1 2011/12/08 12:01:55 johu Exp $
+
+EAPI=4
+
+inherit versionator kde4-base
+
+DESCRIPTION="BibTeX editor for KDE to edit bibliographies used with LaTeX"
+HOMEPAGE="http://home.gna.org/kbibtex/"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P/_/-}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ ESVN_REPO_URI="svn://svn.gna.org/svn/${PN}/trunk"
+ ESVN_PROJECT="${PN}"
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ app-text/poppler[qt4]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ virtual/tex-base
+"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html"
+
+S=${WORKDIR}/${P/_/-}