summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libvirt/libvirt-9999.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild37
1 files changed, 24 insertions, 13 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 511fcab8b52f..96405f76920d 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.81 2015/07/25 22:06:10 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.82 2015/07/28 16:54:00 tamiko Exp $
EAPI=5
@@ -132,16 +132,22 @@ If you are using dnsmasq on your system, you will have to configure
interface or except-interface
Otherwise you might have issues with your existing DNS server.
-The systemd service-file configuration under /etc/sysconfig has been
-removed. Please use
- /etc/systemd/system/libvirtd.service.d/00gentoo.conf
-to control the '--listen' parameter for libvirtd.
+For openrc users:
-The configuration for the 'libvirt-guests.service' is now found under
- /etc/libvirt/libvirt-guests.conf
+ Please use /etc/conf.d/libvirtd to control the '--listen' parameter for
+ libvirtd.
-The openrc configuration has not been changed. Thus no action is required
-for the openrc service manager."
+ The default configuration will keep kvm guests running upon daemon
+ restart and will shut down kvm guests if the libvirtd daemon is
+ stopped. This behavior can be changed under /etc/conf.d/libvirtd
+
+For systemd users:
+
+ Please use /etc/systemd/system/libvirtd.service.d/00gentoo.conf
+ to control the '--listen' parameter for libvirtd.
+
+ The configuration for the 'libvirt-guests.service' is found under
+ /etc/libvirt/libvirt-guests.conf"
! use policykit && DOC_CONTENTS+="
@@ -252,7 +258,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-1.2.9-do_not_use_sysconf.patch \
- "${FILESDIR}"/${PN}-1.2.16-fix_paths_in_libvirt-guests_sh.patch
+ "${FILESDIR}"/${PN}-1.2.16-fix_paths_in_libvirt-guests_sh.patch \
+ "${FILESDIR}"/${P}-fix_paths_for_apparmor.patch
[[ -n ${BACKPORTS} ]] && \
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" \
@@ -267,7 +274,7 @@ src_prepare() {
local iscsi_init=
local rbd_init=
local firewalld_init=
- cp "${FILESDIR}/libvirtd.init-r15" "${S}/libvirtd.init"
+ cp "${FILESDIR}/libvirtd.init-r16" "${S}/libvirtd.init"
use avahi && avahi_init='avahi-daemon'
use iscsi && iscsi_init='iscsid'
use rbd && rbd_init='ceph'
@@ -420,7 +427,7 @@ src_install() {
# Remove bogus, empty directories. They are either not used, or
# libvirtd is able to create them on demand
- rm -rf "${D}"/etc/sysconf
+ rm -rf "${D}"/etc/sysconfig
rm -rf "${D}"/var/cache
rm -rf "${D}"/var/run
rm -rf "${D}"/var/log
@@ -434,7 +441,7 @@ src_install() {
systemd_newtmpfilesd "${FILESDIR}"/libvirtd.tmpfiles.conf libvirtd.conf
newinitd "${S}/libvirtd.init" libvirtd || die
- newconfd "${FILESDIR}/libvirtd.confd-r5" libvirtd || die
+ newconfd "${FILESDIR}/libvirtd.confd-r6" libvirtd || die
newinitd "${FILESDIR}/virtlockd.init-r1" virtlockd || die
readme.gentoo_create_doc
@@ -465,5 +472,9 @@ pkg_postinst() {
use libvirtd || return 0
# From here, only libvirtd-related instructions, be warned!
+ if [[ -n ${REPLACING_VERSIONS} ]] && ! version_is_at_least 1.2.17-r2 ${REPLACING_VERSIONS} ]]; then
+ FORCE_PRINT_ELOG=true
+ fi
+
readme.gentoo_print_elog
}