summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/freesci/freesci-0.3.4a.ebuild')
-rw-r--r--app-emulation/freesci/freesci-0.3.4a.ebuild41
1 files changed, 24 insertions, 17 deletions
diff --git a/app-emulation/freesci/freesci-0.3.4a.ebuild b/app-emulation/freesci/freesci-0.3.4a.ebuild
index 8b9128335434..d20674daf22e 100644
--- a/app-emulation/freesci/freesci-0.3.4a.ebuild
+++ b/app-emulation/freesci/freesci-0.3.4a.ebuild
@@ -1,33 +1,40 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/freesci/freesci-0.3.4a.ebuild,v 1.2 2003/06/29 20:06:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/freesci/freesci-0.3.4a.ebuild,v 1.3 2003/07/13 22:51:24 vapier Exp $
+
+inherit games flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="Sierra script interpreter for your old Sierra adventures"
-SRC_URI="http://savannah.nongnu.org/download/freesci/stable.pkg/${PV}/${P}.tar.bz2"
+SRC_URI="http://savannah.nongnu.org/download/freesci/stable.pkg/${PV}/${P}.tar.bz2
+ http://teksolv.de/~jameson/${P}.tar.bz2"
HOMEPAGE="http://freesci.linuxgames.com/"
+
LICENSE="GPL-2"
KEYWORDS="x86"
SLOT="0"
-IUSE=""
+IUSE="X ggi directfb alsa sdl ncurses"
-DEPEND="virtual/x11"
+DEPEND="X? ( virtual/x11 =media-libs/freetype-2* )
+ ggi? ( media-libs/libggi )
+ directfb? ( dev-libs/DirectFB )
+ alsa? ( >=media-libs/alsa-lib-0.5.0 )
+ sdl? ( >=media-libs/libsdl-1.1.8 )
+ ncurses? ( sys-libs/ncurses )"
src_compile() {
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man || die "./configure failed"
-
+ use X && append-flags -I/usr/include/freetype2
+ egamesconf \
+ `use_with X x` \
+ `use_with sdl` \
+ `use_with directfb` \
+ `use_with ggi` \
+ `use_with alsa` \
+ || die
emake || die
-
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
-
- dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README README.Unix THANKS TODO
-
+ dodoc AUTHORS ChangeLog INSTALL NEWS README README.Unix THANKS TODO
+ prepgamesdirs
}