summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild')
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild
index b5efd6d2c497..02578a426fdf 100644
--- a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild,v 1.1 2008/03/01 00:22:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080301.ebuild,v 1.2 2008/03/01 14:13:54 ulm Exp $
inherit elisp
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND=">=app-emacs/nxml-mode-20041004-r3"
+RDEPEND="|| ( >=app-emacs/nxml-mode-20041004-r3 >=virtual/emacs-23 )"
SITEFILE=60${PN}-gentoo.el
@@ -25,3 +25,13 @@ src_install() {
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
dodoc DONATING
}
+
+pkg_postinst () {
+ elisp-site-regen
+
+ if [ $(emacs -batch -q --eval "(princ (fboundp 'nxml-mode))") = nil ]; then
+ ewarn "This package needs nxml-mode. You should either install"
+ ewarn "app-emacs/nxml-mode, or use \"eselect emacs\" to select"
+ ewarn "an Emacs version >= 23."
+ fi
+}