summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/aspell-pt/files/Makefile-fix')
-rw-r--r--app-dicts/aspell-pt/files/Makefile-fix27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-dicts/aspell-pt/files/Makefile-fix b/app-dicts/aspell-pt/files/Makefile-fix
new file mode 100644
index 000000000000..f262a34a53e4
--- /dev/null
+++ b/app-dicts/aspell-pt/files/Makefile-fix
@@ -0,0 +1,27 @@
+--- Makefile 2001-06-29 18:31:25.000000000 +0200
++++ ../Makefile 2005-02-06 21:43:07.838584616 +0100
+@@ -1,20 +1,17 @@
++include config.mak
++
+ DICT = portugues.aspell
+
+ CONFIG = portugues.dat
+ PHONET = portugues_phone.dat
+
+-pkgdatadir = `aspell dump config | grep '^. data-dir current' | sed 's/^.*: \(.*\)$$/\1/'`
+-pkglibdir = `aspell dump config | grep '^. dict-dir current' | sed 's/^.*: \(.*\)$$/\1/'`
+-pspell_pkgdatadir = `pspell-config pkgdatadir`
+-
+-INSTALL = /usr/bin/install -c
++INSTALL = install -c
+ INSTALL_DATA = ${INSTALL} -m 644
+
+ all: portugues pt-aspell.pwli
+
+ portugues: $(DICT) $(PHONET) $(CONFIG)
+- cp $(pkgdatadir)/iso8859-1.dat ./
+- aspell --data-dir=. --lang=portugues create master ./portugues < $(DICT)
++ aspell --data-dir=${pkgdatadir} --lang=portugues create master ./portugues < $(DICT)
+
+ pt-aspell.pwli:
+ echo $(pkglibdir)/portugues > pt-aspell.pwli