summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/siege/siege-2.60.ebuild')
-rw-r--r--app-benchmarks/siege/siege-2.60.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-benchmarks/siege/siege-2.60.ebuild b/app-benchmarks/siege/siege-2.60.ebuild
new file mode 100644
index 000000000000..0bdaca2c252e
--- /dev/null
+++ b/app-benchmarks/siege/siege-2.60.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.60.ebuild,v 1.1 2004/08/21 18:16:56 kloeri Exp $
+
+DESCRIPTION="An http regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/siege/"
+SRC_URI="ftp://sid.joedog.org/pub/siege/${P}.tar.gz"
+
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+src_compile() {
+ has_version '=dev-libs/openssl-0.9.7*' \
+ && sed -i -e "s:^# include <openssl/e_os.h>::" src/ssl.h
+ local myconf
+ use ssl && myconf="--with-ssl" || myconf="--with-ssl=off"
+ econf ${myconf} || die "econf failed"
+ emake || die
+
+}
+
+src_install() {
+ # makefile tries to install into $HOME by default... bad monkey!
+ dodir /usr/share/doc/${P}
+
+ einstall SIEGERC="${D}/usr/share/doc/${P}/siegerc-example"
+
+ # all non-html docs must be gzip'd
+ gzip ${D}/usr/share/doc/${P}/siegerc-example
+
+ dodoc AUTHORS ChangeLog INSTALL KNOWNBUGS NEWS MACHINES README
+}