summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tmpwatch/tmpwatch-2.9.15.ebuild')
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.9.15.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/tmpwatch-2.9.15.ebuild b/app-admin/tmpwatch/tmpwatch-2.9.15.ebuild
new file mode 100644
index 000000000000..87700d469bc7
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.9.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/tmpwatch-2.9.15.ebuild,v 1.1 2009/07/09 10:19:17 fauli Exp $
+
+DESCRIPTION="Files which haven't been accessed in a given period of time are removed from specified directories"
+HOMEPAGE="https://fedorahosted.org/tmpwatch/"
+SRC_URI="https://fedorahosted.org/releases/t/m/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:..RPM_OPT_FLAGS.:${CFLAGS}:" \
+ -e "s:^CVS:#CVS:g" Makefile \
+ || die "sed Makefile failed"
+ sed -i 's|/sbin/fuser|/bin/fuser|' tmpwatch.c \
+ || die "sed tmpwatch.c failed"
+ sed -i 's|/sbin|/bin|' tmpwatch.8 || die "sed tmpwatch.8 failed"
+}
+
+src_install() {
+ dosbin tmpwatch || die "dosbin failed"
+ doman tmpwatch.8 || die "doman failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die 'failed to install cron'
+}