summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/equo/equo-1.0_rc80.ebuild')
-rw-r--r--app-admin/equo/equo-1.0_rc80.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/equo/equo-1.0_rc80.ebuild b/app-admin/equo/equo-1.0_rc80.ebuild
new file mode 100644
index 000000000000..14188a1eba1a
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc80.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc80.ebuild,v 1.1 2011/12/22 17:51:12 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}