summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/rnaview/ChangeLog10
-rw-r--r--sci-biology/rnaview/rnaview-20040713-r1.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/sci-biology/rnaview/ChangeLog b/sci-biology/rnaview/ChangeLog
index 52e54cd95443..7419dff16e9b 100644
--- a/sci-biology/rnaview/ChangeLog
+++ b/sci-biology/rnaview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/rnaview
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rnaview/ChangeLog,v 1.10 2007/04/10 12:16:39 je_fro Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rnaview/ChangeLog,v 1.11 2008/08/26 18:08:55 ribosome Exp $
+
+*rnaview-20040713-r1 (26 Aug 2008)
+
+ 26 Aug 2008; Olivier Fisette <ribosome@gentoo.org>
+ +rnaview-20040713-r1.ebuild:
+ Added convenience env file.
10 Apr 2007; Jeff Gardner <je_fro@gentoo.org> rnaview-20040713.ebuild:
Added ~amd64.
diff --git a/sci-biology/rnaview/rnaview-20040713-r1.ebuild b/sci-biology/rnaview/rnaview-20040713-r1.ebuild
new file mode 100644
index 000000000000..4bdf64dfd6c1
--- /dev/null
+++ b/sci-biology/rnaview/rnaview-20040713-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rnaview/rnaview-20040713-r1.ebuild,v 1.1 2008/08/26 18:08:55 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
+HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/CC = cc/CC = $(tc-getCC)/" \
+ -e "s/CFLAGS =/CFLAGS = ${CFLAGS}/" \
+ -i Makefile || die
+}
+
+src_compile() {
+ make clean
+ make || die "Failed to build programs."
+ cd "${S}"/rnaml2ps
+ make clean
+ make || die "Failed to build rnaml2ps."
+ cd "${S}"/test
+ rm '.#t'
+}
+
+src_install() {
+ dobin bin/rnaview rnaml2ps/rnaml2ps || die "Failed to install programs."
+ dodoc README || die "Failed to install documentation."
+ mkdir -p "${D}"/usr/share/${PN}
+ cp -r BASEPARS test "${D}"/usr/share/${PN}
+ cat <<- EOF > 22rnaview
+ RNAVIEW="/usr/share/rnaview"
+ EOF
+ doenvd 22rnaview || die "Failed to install environment file."
+}