summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/darcnes/ChangeLog6
-rw-r--r--games-emulation/darcnes/darcnes-0401-r1.ebuild8
-rw-r--r--games-emulation/darcnes/darcnes-0401-r2.ebuild13
3 files changed, 19 insertions, 8 deletions
diff --git a/games-emulation/darcnes/ChangeLog b/games-emulation/darcnes/ChangeLog
index 4d7073b94c31..7a4186cf5770 100644
--- a/games-emulation/darcnes/ChangeLog
+++ b/games-emulation/darcnes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/darcnes
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.5 2004/05/11 00:57:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.6 2004/06/07 03:45:54 agriffis Exp $
+
+ 06 Jun 2004; Aron Griffis <agriffis@gentoo.org> darcnes-0401-r1.ebuild,
+ darcnes-0401-r2.ebuild:
+ Fix use invocation
10 May 2004; Michael Sterrett <mr_bones_@gentoo.org> darcnes-0401-r2.ebuild:
again with the use fun and games
diff --git a/games-emulation/darcnes/darcnes-0401-r1.ebuild b/games-emulation/darcnes/darcnes-0401-r1.ebuild
index ede722bb47f1..5f06d50901b6 100644
--- a/games-emulation/darcnes/darcnes-0401-r1.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r1.ebuild,v 1.2 2004/02/20 06:26:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r1.ebuild,v 1.3 2004/06/07 03:45:54 agriffis Exp $
DESCRIPTION="A multi-system emulator"
SRC_URI="http://www.dridus.com/~nyef/darcnes/download/dn9b${PV}.tgz"
@@ -23,9 +23,9 @@ src_compile() {
cat cd_unix.c.orig | sed "s:CDROM_DEVICE \"/dev/cdrom\"$:CDROM_DEVICE \"/dev/cdroms/cdrom0\":"\
> cd_unix.c
cp Makefile Makefile.orig
- if [ "`use X`" ]
+ if use X
then
- if [ "`use gtk`" ]
+ if use gtk
then
cat Makefile.orig | sed "s:^TARGET?=Linux_X$:TARGET?=Linux_GTK:" \
> Makefile
@@ -41,7 +41,7 @@ src_compile() {
src_install() {
exeinto /usr/bin
doexe sdarcnes
- if [ "`use X`" ]
+ if use X
then
exeinto /usr/bin
doexe darcnes
diff --git a/games-emulation/darcnes/darcnes-0401-r2.ebuild b/games-emulation/darcnes/darcnes-0401-r2.ebuild
index 759235d1bd12..dbbbd9226744 100644
--- a/games-emulation/darcnes/darcnes-0401-r2.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.3 2004/05/11 00:57:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.4 2004/06/07 03:45:54 agriffis Exp $
inherit games
@@ -22,6 +22,13 @@ DEPEND="svga? ( >=media-libs/svgalib-1.4.2 )
S="${WORKDIR}/${PN}"
+pkg_setup() {
+ export build_X=true
+ use svga && build_X=false
+ use gtk && build_X=false
+ use X && build_X=true
+}
+
src_compile() {
if use svga ; then
emake TARGET=Linux_svgalib OPTFLAGS="${CFLAGS}" || \
@@ -31,7 +38,7 @@ src_compile() {
emake BINFILE=gdarcnes TARGET=Linux_GTK OPTFLAGS="${CFLAGS}" || \
die "compile target Linux_GTK failed"
fi
- if use X || use !svga && use !gtk ; then
+ if $build_X ; then
emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" || \
die "compile target Linux_X failed"
fi
@@ -44,7 +51,7 @@ src_install() {
if use gtk ; then
dogamesbin gdarcnes || die "dogamesbin failed (gtk)"
fi
- if use X || use !svga && use !gtk ; then
+ if $build_X ; then
dogamesbin darcnes || die "dogamesbin failed"
fi
dodoc readme