summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/twisted/Manifest6
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.7_alpha41
-rw-r--r--dev-python/twisted/twisted-1.0.7_alpha4.ebuild44
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index 44c286cf97ec..aa27c1108a64 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -1,4 +1,6 @@
-MD5 7b72afa2517437dbde778c70b4e19af2 files/digest-twisted-1.0.6 67
-MD5 ae50eec0652f8d2df8d6bed4012d9e9b ChangeLog 6145
MD5 3c48d9afb61b5911c632c194c4fd0a51 twisted-1.0.6.ebuild 1222
+MD5 aea221a0a66d8244084e4118b0616a9e twisted-1.0.7_alpha4.ebuild 1282
+MD5 ae50eec0652f8d2df8d6bed4012d9e9b ChangeLog 6145
MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
+MD5 7b72afa2517437dbde778c70b4e19af2 files/digest-twisted-1.0.6 67
+MD5 f216e6bf82bd3cb707af252c96ed8e44 files/digest-twisted-1.0.7_alpha4 73
diff --git a/dev-python/twisted/files/digest-twisted-1.0.7_alpha4 b/dev-python/twisted/files/digest-twisted-1.0.7_alpha4
new file mode 100644
index 000000000000..e4f040df6572
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.7_alpha4
@@ -0,0 +1 @@
+MD5 50865a6954543d9bd7fcb936125a9f84 Twisted-1.0.7alpha4.tar.bz2 3741360
diff --git a/dev-python/twisted/twisted-1.0.7_alpha4.ebuild b/dev-python/twisted/twisted-1.0.7_alpha4.ebuild
new file mode 100644
index 000000000000..c97ff87798cb
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.7_alpha4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.7_alpha4.ebuild,v 1.1 2003/08/20 13:02:07 lordvan Exp $
+
+IUSE="gtk2 doc"
+
+MY_PV="1.0.7alpha4"
+S=${WORKDIR}/Twisted-${MY_PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${MY_PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND=">=dev-lang/python-2.2*
+ >=dev-python/pycrypto-1.9_alpha4
+ gtk? ( =dev-python/pygtk-0.6* )
+ gtk2? ( >=dev-python/pygtk-1.99* )"
+KEYWORDS="~x86 ~alpha ~sparc"
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+
+ # next few lines will install docs: 9.4 megs!
+ if [ -n "`use doc`" ]; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp -r . ${D}/usr/share/doc/${PF}
+ fi
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+
+}
+