summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-3.2_p39.ebuild8
-rw-r--r--app-shells/bash/bash-3.2_p48-r1.ebuild8
-rw-r--r--app-shells/bash/bash-3.2_p48.ebuild10
-rw-r--r--app-shells/bash/bash-4.0.ebuild8
5 files changed, 11 insertions, 30 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index e16bfa867927..0671627e8e1c 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.202 2009/02/25 17:22:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.203 2009/02/25 21:20:55 vapier Exp $
+
+ 25 Feb 2009; Mike Frysinger <vapier@gentoo.org> bash-3.2_p39.ebuild,
+ bash-3.2_p48.ebuild, bash-3.2_p48-r1.ebuild, bash-4.0.ebuild:
+ Stop auto-removing bash_logout in pkg_preinst() as this confuses newer
+ versions of portage.
25 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+files/bash-4.0-declare-identifier.patch, bash-4.0.ebuild:
diff --git a/app-shells/bash/bash-3.2_p39.ebuild b/app-shells/bash/bash-3.2_p39.ebuild
index 0865dfc1c4ed..dd8ef70b55f8 100644
--- a/app-shells/bash/bash-3.2_p39.ebuild
+++ b/app-shells/bash/bash-3.2_p39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p39.ebuild,v 1.17 2009/02/21 21:58:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p39.ebuild,v 1.18 2009/02/25 21:20:55 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -177,12 +177,6 @@ pkg_preinst() {
mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
fi
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-
if [[ -L ${ROOT}/bin/sh ]]; then
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
diff --git a/app-shells/bash/bash-3.2_p48-r1.ebuild b/app-shells/bash/bash-3.2_p48-r1.ebuild
index fd009dbd5c34..99838b9a01c2 100644
--- a/app-shells/bash/bash-3.2_p48-r1.ebuild
+++ b/app-shells/bash/bash-3.2_p48-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p48-r1.ebuild,v 1.2 2009/02/21 23:01:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p48-r1.ebuild,v 1.3 2009/02/25 21:20:55 vapier Exp $
EAPI=1
@@ -182,12 +182,6 @@ pkg_preinst() {
mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
fi
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-
if [[ -L ${ROOT}/bin/sh ]]; then
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
diff --git a/app-shells/bash/bash-3.2_p48.ebuild b/app-shells/bash/bash-3.2_p48.ebuild
index d797a795d5c6..a500f9d75d29 100644
--- a/app-shells/bash/bash-3.2_p48.ebuild
+++ b/app-shells/bash/bash-3.2_p48.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p48.ebuild,v 1.1 2008/11/20 20:57:20 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p48.ebuild,v 1.2 2009/02/25 21:20:55 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -177,12 +177,6 @@ pkg_preinst() {
mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
fi
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-
if [[ -L ${ROOT}/bin/sh ]]; then
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
diff --git a/app-shells/bash/bash-4.0.ebuild b/app-shells/bash/bash-4.0.ebuild
index 87b649acea68..5f92949aba6b 100644
--- a/app-shells/bash/bash-4.0.ebuild
+++ b/app-shells/bash/bash-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.7 2009/02/25 17:22:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.8 2009/02/25 21:20:55 vapier Exp $
EAPI="1"
@@ -174,12 +174,6 @@ pkg_preinst() {
mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
fi
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-
if [[ -L ${ROOT}/bin/sh ]]; then
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.