summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/abs-guide/ChangeLog10
-rw-r--r--app-doc/abs-guide/abs-guide-6.0.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/app-doc/abs-guide/ChangeLog b/app-doc/abs-guide/ChangeLog
index 23dfb8d8f5cf..353adc14b2e3 100644
--- a/app-doc/abs-guide/ChangeLog
+++ b/app-doc/abs-guide/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-doc/abs-guide
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/abs-guide/ChangeLog,v 1.67 2008/12/07 03:41:04 dirtyepic Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/abs-guide/ChangeLog,v 1.68 2009/03/29 05:41:21 dirtyepic Exp $
+
+*abs-guide-6.0 (29 Mar 2009)
+
+ 29 Mar 2009; Ryan Hill <dirtyepic@gentoo.org> +abs-guide-6.0.ebuild:
+ Version bump, now covers Bash 4.
+ Add pdf USE flag to install pdf version.
07 Dec 2008; Ryan Hill <dirtyepic@gentoo.org> -abs-guide-5.3.ebuild,
abs-guide-5.5.ebuild:
diff --git a/app-doc/abs-guide/abs-guide-6.0.ebuild b/app-doc/abs-guide/abs-guide-6.0.ebuild
new file mode 100644
index 000000000000..61611e340c1f
--- /dev/null
+++ b/app-doc/abs-guide/abs-guide-6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/abs-guide/abs-guide-6.0.ebuild,v 1.1 2009/03/29 05:41:21 dirtyepic Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DESCRIPTION="An advanced reference and a tutorial on bash shell scripting"
+HOMEPAGE="http://www.tldp.org/LDP/abs/html"
+
+# Upstream likes to update the tarball without changing the name.
+# - fetch http://bash.neuralshortcircuit.com/abs-guide-latest.tar.bz2
+# rename to abs-guide-${PV}.tar.bz2
+# - fetch http://bash.neuralshortcircuit.com/abs-guide.pdf
+# rename to abs-guide-${PV}.pdf
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ pdf? ( mirror://gentoo/${P}.pdf )"
+
+LICENSE="OPL"
+IUSE="pdf"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/abs"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use pdf && cp "${DISTDIR}"/${P}.pdf "${S}"
+ cd "${S}"
+}
+
+src_install() {
+ dodir /usr/share/doc/${P} || die "dodir failed"
+ cp -R * "${D}"/usr/share/doc/${P} || die "cp failed"
+ use pdf && { cp ${P}.pdf "${D}"/usr/share/doc/${P} || die "pdf failed"; }
+}