summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/subtle/ChangeLog11
-rw-r--r--x11-wm/subtle/metadata.xml27
-rw-r--r--x11-wm/subtle/subtle-0.10.3008.ebuild84
-rw-r--r--x11-wm/subtle/subtle-9999.ebuild86
4 files changed, 208 insertions, 0 deletions
diff --git a/x11-wm/subtle/ChangeLog b/x11-wm/subtle/ChangeLog
new file mode 100644
index 000000000000..ccb8203eee0d
--- /dev/null
+++ b/x11-wm/subtle/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-wm/subtle
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/ChangeLog,v 1.1 2011/09/13 09:50:32 radhermit Exp $
+
+*subtle-9999 (13 Sep 2011)
+*subtle-0.10.3008 (13 Sep 2011)
+
+ 13 Sep 2011; Tim Harder <radhermit@gentoo.org> +subtle-0.10.3008.ebuild,
+ +subtle-9999.ebuild, +metadata.xml:
+ Initial import (fixes bug #280043 by Tommie).
+
diff --git a/x11-wm/subtle/metadata.xml b/x11-wm/subtle/metadata.xml
new file mode 100644
index 000000000000..d49f0f04048f
--- /dev/null
+++ b/x11-wm/subtle/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">
+ subtle is a manual tiling window manager with a rather uncommon approach
+ of tiling: Instead of relying on predefined layouts, subtle divides the
+ screen into a grid with customizeable slots (called gravities). For
+ better understanding, the default config uses a 3x3 grid and maps each
+ gravity to one key of the numpad. With those keys, windows can be moved
+ directly to the desired gravity - the same can be done with tagging
+ rules in the config.
+
+ Another unique concept is the strict tagging: Unlike other tiling window
+ managers, subtle doesn't allow weak tagging and always maps windows to
+ virtual desktops (called views) with matching tags, regardless of the
+ current active view.
+ </longdescription>
+ <use>
+ <flag name='xrandr'>Enable support for the X RandR extension</flag>
+ <flag name='xtest'>Enable support for the XTest extension</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-wm/subtle/subtle-0.10.3008.ebuild b/x11-wm/subtle/subtle-0.10.3008.ebuild
new file mode 100644
index 000000000000..e26a5e95c511
--- /dev/null
+++ b/x11-wm/subtle/subtle-0.10.3008.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/subtle-0.10.3008.ebuild,v 1.1 2011/09/13 09:50:32 radhermit Exp $
+
+EAPI="4"
+USE_RUBY="ruby19"
+
+inherit ruby-ng
+
+GR="nu"
+
+DESCRIPTION="A manual tiling window manager"
+HOMEPAGE="http://subforge.org/projects/subtle/wiki"
+SRC_URI="http://subforge.org/attachments/download/75/${P}-${GR}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test +xft xinerama xpm +xrandr +xtest"
+
+RDEPEND="x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ xtest? ( x11-libs/libXtst )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}"
+# test? (
+# x11-terms/xterm
+# x11-base/xorg-server[xvfb]
+# )"
+
+ruby_add_rdepend "dev-ruby/archive-tar-minitar"
+ruby_add_bdepend "dev-ruby/rake"
+
+RUBY_S="${P}-${GR}"
+
+# Requires dev-ruby/riot which isn't in the tree yet
+RESTRICT="test"
+
+each_ruby_configure() {
+ local myconf
+ use debug && myconf+=" debug=yes" || myconf+=" debug=no"
+ use xft && myconf+=" xft=yes" || myconf+=" xft=no"
+ use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
+ use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
+ use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
+ use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
+
+ ${RUBY} -S rake destdir="${D}" ${myconf} config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake build || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/test.rb || die "tests failed"
+}
+
+each_ruby_install() {
+ ${RUBY} -S rake install || die
+}
+
+all_ruby_install() {
+ dodir /etc/X11/Sessions
+ cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
+ #!/bin/sh
+ /usr/bin/subtle
+ EOF
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ dodoc AUTHORS NEWS
+
+ if use doc ; then
+ rake rdoc || die
+ dohtml -r html/*
+ fi
+}
+
+pkg_postinst() {
+ elog "Note that surserver will currently not work since dev-ruby/datamapper"
+ elog "is not in the tree yet."
+}
diff --git a/x11-wm/subtle/subtle-9999.ebuild b/x11-wm/subtle/subtle-9999.ebuild
new file mode 100644
index 000000000000..3bda66932a10
--- /dev/null
+++ b/x11-wm/subtle/subtle-9999.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/subtle-9999.ebuild,v 1.1 2011/09/13 09:50:32 radhermit Exp $
+
+EAPI="4"
+USE_RUBY="ruby19"
+
+inherit mercurial ruby-ng
+
+EHG_REPO_URI="http://hg.subforge.org/subtle"
+
+DESCRIPTION="A manual tiling window manager"
+HOMEPAGE="http://subforge.org/projects/subtle/wiki"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug doc test +xft xinerama xpm +xrandr +xtest"
+
+RDEPEND="x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ xtest? ( x11-libs/libXtst )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}"
+# test? (
+# x11-terms/xterm
+# x11-base/xorg-server[xvfb]
+# )"
+
+ruby_add_rdepend "dev-ruby/archive-tar-minitar"
+ruby_add_bdepend "dev-ruby/rake"
+
+# Requires dev-ruby/riot which isn't in the tree yet
+RESTRICT="test"
+
+all_ruby_unpack() {
+ mercurial_src_unpack
+}
+
+each_ruby_configure() {
+ local myconf
+ use debug && myconf+=" debug=yes" || myconf+=" debug=no"
+ use xft && myconf+=" xft=yes" || myconf+=" xft=no"
+ use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
+ use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
+ use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
+ use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
+
+ ${RUBY} -S rake destdir="${D}" ${myconf} config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake build || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/test.rb || die "tests failed"
+}
+
+each_ruby_install() {
+ ${RUBY} -S rake install || die
+}
+
+all_ruby_install() {
+ dodir /etc/X11/Sessions
+ cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
+ #!/bin/sh
+ /usr/bin/subtle
+ EOF
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ dodoc AUTHORS NEWS
+
+ if use doc ; then
+ rake rdoc || die
+ dohtml -r html/*
+ fi
+}
+
+pkg_postinst() {
+ elog "Note that surserver will currently not work since dev-ruby/datamapper"
+ elog "is not in the tree yet."
+}