summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/llfuse/ChangeLog7
-rw-r--r--dev-python/llfuse/llfuse-0.40.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/llfuse/ChangeLog b/dev-python/llfuse/ChangeLog
index 26852651726a..a1b04c84979d 100644
--- a/dev-python/llfuse/ChangeLog
+++ b/dev-python/llfuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/llfuse
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/ChangeLog,v 1.14 2013/09/05 18:46:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/ChangeLog,v 1.15 2013/12/03 02:14:47 radhermit Exp $
+
+*llfuse-0.40 (03 Dec 2013)
+
+ 03 Dec 2013; Tim Harder <radhermit@gentoo.org> +llfuse-0.40.ebuild:
+ Version bump.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> llfuse-0.39.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/llfuse/llfuse-0.40.ebuild b/dev-python/llfuse/llfuse-0.40.ebuild
new file mode 100644
index 000000000000..088222a77069
--- /dev/null
+++ b/dev-python/llfuse/llfuse-0.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/llfuse-0.40.ebuild,v 1.1 2013/12/03 02:14:48 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="http://python-llfuse.googlecode.com/ http://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=sys-fs/fuse-2.8.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # use system setuptools
+ sed -i '/use_setuptools/d' setup.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}