summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/gupnp-igd/ChangeLog7
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index 6ebcd647dc38..061866a0b43c 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp-igd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.14 2010/02/19 19:03:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.15 2010/08/01 08:54:36 pacho Exp $
+
+*gupnp-igd-0.1.7 (01 Aug 2010)
+
+ 01 Aug 2010; Pacho Ramos <pacho@gentoo.org> +gupnp-igd-0.1.7.ebuild:
+ Version bump with simple bug fixes and also letting tests to work.
19 Feb 2010; Raúl Porcel <armin76@gentoo.org> gupnp-igd-0.1.3.ebuild:
ia64/sparc stable
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild
new file mode 100644
index 000000000000..d2af61eaaad2
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild,v 1.1 2010/08/01 08:54:36 pacho Exp $
+
+EAPI=2
+
+DESCRIPTION="This is a library to handle UPnP IGD port mapping for GUPnP."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://www.gupnp.org/sites/all/files/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+RDEPEND=">=net-libs/gupnp-0.13.2
+ >=dev-libs/glib-2.16:2
+ python? ( >=dev-python/pygobject-2.16 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ $(use_enable python) \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README TODO
+}