summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-bibtex/ChangeLog7
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/python-bibtex/ChangeLog b/dev-python/python-bibtex/ChangeLog
index f45dc0dba441..2ccc888d45f5 100644
--- a/dev-python/python-bibtex/ChangeLog
+++ b/dev-python/python-bibtex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-bibtex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-bibtex/ChangeLog,v 1.28 2014/05/03 09:15:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-bibtex/ChangeLog,v 1.29 2014/12/25 12:12:18 mgorny Exp $
+
+*python-bibtex-1.2.7-r1 (25 Dec 2014)
+
+ 25 Dec 2014; Michał Górny <mgorny@gentoo.org> +python-bibtex-1.2.7-r1.ebuild:
+ Convert to distutils-r1.
*python-bibtex-1.2.7 (03 May 2014)
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..3c99f8acf903
--- /dev/null
+++ b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild,v 1.1 2014/12/25 12:12:18 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python extension to parse BibTeX files"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ >=app-text/recode-3.6-r1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # Disable tests during installation.
+ sed -e "/self.run_command ('check')/d" -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py check
+}