summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/x2goclient/ChangeLog8
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.2.1.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/net-misc/x2goclient/ChangeLog b/net-misc/x2goclient/ChangeLog
index 25a93ee36a2c..f49a4dea12a7 100644
--- a/net-misc/x2goclient/ChangeLog
+++ b/net-misc/x2goclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/x2goclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.31 2014/06/14 22:15:17 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.32 2014/08/05 09:17:04 voyageur Exp $
+
+*x2goclient-4.0.2.1 (05 Aug 2014)
+
+ 05 Aug 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +x2goclient-4.0.2.1.ebuild:
+ Version bump
14 Jun 2014; Mikle Kolyada <zlogene@gentoo.org> x2goclient-4.0.2.0.ebuild:
amd64 stable wrt bug #510944
diff --git a/net-misc/x2goclient/x2goclient-4.0.2.1.ebuild b/net-misc/x2goclient/x2goclient-4.0.2.1.ebuild
new file mode 100644
index 000000000000..a6465f1a84ff
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.2.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.2.1.ebuild,v 1.1 2014/08/05 09:17:04 voyageur Exp $
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}