summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/diradm/ChangeLog6
-rw-r--r--app-admin/diradm/diradm-2.9.3.ebuild24
-rw-r--r--app-admin/diradm/diradm-2.9.6.ebuild27
3 files changed, 31 insertions, 26 deletions
diff --git a/app-admin/diradm/ChangeLog b/app-admin/diradm/ChangeLog
index 96a51dd8e3dc..5836329c04c6 100644
--- a/app-admin/diradm/ChangeLog
+++ b/app-admin/diradm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/diradm
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/ChangeLog,v 1.36 2009/03/09 20:52:52 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/ChangeLog,v 1.37 2009/03/09 21:14:53 betelgeuse Exp $
+
+ 09 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> diradm-2.9.3.ebuild,
+ diradm-2.9.6.ebuild:
+ Migrate to EAPI 2.
09 Mar 2009; Robin H. Johnson <robbat2@gentoo.org> -diradm-1.1.ebuild,
-diradm-1.1-r1.ebuild, -diradm-1.2.ebuild, -diradm-2.1.ebuild,
diff --git a/app-admin/diradm/diradm-2.9.3.ebuild b/app-admin/diradm/diradm-2.9.3.ebuild
index c8aa29822182..6dae7b51218d 100644
--- a/app-admin/diradm/diradm-2.9.3.ebuild
+++ b/app-admin/diradm/diradm-2.9.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.3.ebuild,v 1.6 2008/02/20 23:03:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.3.ebuild,v 1.7 2009/03/09 21:14:53 betelgeuse Exp $
+
+EAPI="2"
inherit eutils
@@ -26,18 +28,18 @@ DEPEND="net-nds/openldap
dev-perl/Crypt-SmbHash
>=net-fs/samba-3.0.6
)
- test? ( dev-perl/Crypt-SmbHash >=net-fs/samba-3.0.6 dev-util/dejagnu )"
+ test? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ dev-util/dejagnu
+ net-nds/openldap[-minimal]
+ )"
pkg_setup() {
- if use test; then
- if built_with_use net-nds/openldap minimal ; then
- die "You MUST have a non-minimal build of OpenLDAP to use the testcases!"
- fi
- elog "Warning, for test usage, diradm is built with all optional features!"
- fi
+ use test && elog "Warning, for test usage, diradm is built with all optional features!"
}
-src_compile() {
+src_configure() {
local myconf
if use test; then
myconf="--enable-samba --enable-automount --enable-irixpasswd"
@@ -45,7 +47,6 @@ src_compile() {
myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
fi
econf ${myconf} || die "econf failed"
- emake || die "emake failed"
}
src_install() {
@@ -64,6 +65,5 @@ pkg_postinst() {
}
src_test() {
- use test || die "You must build diradm with USE=test to run the testcases!"
emake -j1 check
}
diff --git a/app-admin/diradm/diradm-2.9.6.ebuild b/app-admin/diradm/diradm-2.9.6.ebuild
index b0807e7fef75..cc026107fd31 100644
--- a/app-admin/diradm/diradm-2.9.6.ebuild
+++ b/app-admin/diradm/diradm-2.9.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.6.ebuild,v 1.1 2008/09/25 05:53:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.6.ebuild,v 1.2 2009/03/09 21:14:53 betelgeuse Exp $
+
+EAPI="2"
inherit eutils
@@ -26,18 +28,18 @@ DEPEND=">=net-nds/openldap-2.3
dev-perl/Crypt-SmbHash
>=net-fs/samba-3.0.6
)
- test? ( dev-perl/Crypt-SmbHash >=net-fs/samba-3.0.6 dev-util/dejagnu )"
+ test? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ dev-util/dejagnu
+ net-nds/openldap[-minimal]
+ )"
pkg_setup() {
- if use test; then
- if built_with_use net-nds/openldap minimal ; then
- die "You MUST have a non-minimal build of OpenLDAP to use the testcases!"
- fi
- elog "Warning, for test usage, diradm is built with all optional features!"
- fi
+ use test && elog "Warning, for test usage, diradm is built with all optional features!"
}
-src_compile() {
+src_configure() {
local myconf
if use test; then
myconf="--enable-samba --enable-automount --enable-irixpasswd"
@@ -45,12 +47,12 @@ src_compile() {
myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
fi
econf ${myconf} || die "econf failed"
- emake || die "emake failed"
}
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
- dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork THANKS TODO KNOWN-BUGS
+ dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork \
+ THANKS TODO KNOWN-BUGS || die
if use irixpasswd; then
insinto /etc/openldap/schema
doins irixpassword.schema
@@ -64,6 +66,5 @@ pkg_postinst() {
}
src_test() {
- use test || die "You must build diradm with USE=test to run the testcases!"
emake -j1 check
}