summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/wvstreams/ChangeLog10
-rw-r--r--net-libs/wvstreams/Manifest3
-rw-r--r--net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch9
-rw-r--r--net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch24
-rw-r--r--net-libs/wvstreams/wvstreams-3.75.ebuild24
5 files changed, 66 insertions, 4 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 2ffdabf1ee6d..d4a8ebb21811 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.19 2004/07/01 22:27:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.20 2004/08/12 22:39:30 aliz Exp $
+
+*wvstreams-3.75-r1 (12 Aug 2004)
+
+ 12 Aug 2004; Daniel Ahlberg <aliz@gentoo.org> wvstreams-3.75-r1.ebuild,
+ wvstreams-3.75.ebuild, files/wvstreams-3.75-fPIC.patch,
+ files/wvstreams-3.75-tcl_8_4.patch:
+ Added tcltk and fftw dependencies. Added swig to dependencies if tcl installed
+ and a patch for fixing tcl 8.4 support. Closing #59601.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
wvstreams-3.70-r2.ebuild, wvstreams-3.74.ebuild, wvstreams-3.75.ebuild:
diff --git a/net-libs/wvstreams/Manifest b/net-libs/wvstreams/Manifest
index 3564d722a2a0..3dbaaabe55bf 100644
--- a/net-libs/wvstreams/Manifest
+++ b/net-libs/wvstreams/Manifest
@@ -1,4 +1,5 @@
MD5 84906df12ff06c74e269a55f292f09ac wvstreams-3.70-r2.ebuild 869
+MD5 414a9bf053e1e67a247e183edc0f7950 wvstreams-3.75-r1.ebuild 1648
MD5 72dfe55e485bf5d2ac8d42c902df7ea5 wvstreams-3.75.ebuild 1447
MD5 1df223cd3261533626bd3efc2d4bcd4a wvstreams-3.74.ebuild 1274
MD5 aaeadce7ba11146f7aa50d3d191b4524 ChangeLog 2551
@@ -11,4 +12,6 @@ MD5 185e2acbb79c70873208936653ff2407 files/wvstreams-3.74-fPIC.patch 431
MD5 1ac6673ae2b040012b3ff91a32335610 files/wvstreams-3.75-fPIC.patch 1197
MD5 c48022170e1e20f8222af4b4711373eb files/wvstreams-3.74-makefile.patch 363
MD5 f2058097f693e07dadf248b1a3319db3 files/digest-wvstreams-3.70-r2 66
+MD5 9f5fc56a6f1636fa2b6673a16888c0ea files/digest-wvstreams-3.75-r1 68
MD5 b8b38bbbccf83a9024a243149fd9b7d1 files/wvstreams-3.70-gentoo.patch 1174
+MD5 9538182e8468da9c31aa0f9b351a619c files/wvstreams-3.75-tcl_8_4.patch 541
diff --git a/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch b/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch
index 988f5e3e9399..dce6a8be9470 100644
--- a/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch
+++ b/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch
@@ -29,3 +29,12 @@
+qt/wvqtstreamclone.fpic.o: include/wvqtstreamclone.moc
+qt/wvqthook.fpic.o: include/wvqthook.moc
+--- vars.mk 2004-08-12 22:07:41.902797093 +0000
++++ vars.mk 2004-08-12 22:16:37.327729755 +0000
+@@ -181,3 +181,6 @@
+ libuniconf_tcl.so: bindings/uniconf_tcl.o -ltcl8.4 -luniconf
+
+ uniconf/daemon/uniconfdaemon: libuniconf.so libwvutils.so -ldb
++
++bindings/uniconf_tcl.o: bindings/uniconf_tcl.c
++ $(call wvcc ,$@,$<,$*,-fPIC)
diff --git a/net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch b/net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch
new file mode 100644
index 000000000000..97bb2328827d
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch
@@ -0,0 +1,24 @@
+--- configure.ac 2004-08-12 19:35:56.695660963 +0000
++++ configure.ac 2004-08-12 19:36:26.232540924 +0000
+@@ -202,9 +202,9 @@
+ # tcl
+ if test "$with_tcl" != "no"; then
+ CPPFLAGS_save="$CPPFLAGS"
+- WV_APPEND(CPPFLAGS, -I/usr/include/tcl8.3)
++ WV_APPEND(CPPFLAGS, -I/usr/include/tcl8.4)
+ AC_CHECK_HEADERS(tcl.h,, [with_tcl=no])
+- AC_CHECK_LIB(tcl8.3, TclInterpInit,, [with_tcl=no])
++ AC_CHECK_LIB(tcl8.4, TclInterpInit,, [with_tcl=no])
+ if test "$with_tcl" != "no"; then
+ CPPFLAGS="$CPPFLAGS_save"
+ fi
+--- vars.mk 2004-08-12 21:32:32.627250401 +0000
++++ vars.mk 2004-08-12 21:32:39.932489430 +0000
+@@ -178,6 +178,6 @@
+ libwvgtk.a libwvgtk.so: $(call objects,gtk)
+ libwvgtk.so: -lgtk -lgdk libwvstreams.so libwvutils.so
+
+-libuniconf_tcl.so: bindings/uniconf_tcl.o -ltcl8.3 -luniconf
++libuniconf_tcl.so: bindings/uniconf_tcl.o -ltcl8.4 -luniconf
+
+ uniconf/daemon/uniconfdaemon: libuniconf.so libwvutils.so -ldb
diff --git a/net-libs/wvstreams/wvstreams-3.75.ebuild b/net-libs/wvstreams/wvstreams-3.75.ebuild
index b6d4e9fe4004..5494913e62c5 100644
--- a/net-libs/wvstreams/wvstreams-3.75.ebuild
+++ b/net-libs/wvstreams/wvstreams-3.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.75.ebuild,v 1.7 2004/07/13 21:47:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.75.ebuild,v 1.8 2004/08/12 22:39:30 aliz Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="http://people.nit.ca/~jim/${P}.0.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc -alpha ~amd64 -hppa ~ppc"
-IUSE="gtk qt oggvorbis speex fam gdbm pam"
+IUSE="gtk qt oggvorbis speex fam gdbm pam fftw tcltk"
RDEPEND="gtk? ( >=x11-libs/gtk+-2.2.0 )
qt? ( >=x11-libs/qt-3.0.5 )
@@ -24,11 +24,22 @@ RDEPEND="gtk? ( >=x11-libs/gtk+-2.2.0 )
gdbm? ( >=sys-libs/gdbm-1.8.0 )
pam? ( >=sys-libs/pam-0.75 )
>=sys-libs/zlib-1.1.4
- dev-libs/openssl"
+ dev-libs/openssl
+ fftw? ( dev-libs/fftw )
+ tcltk? ( dev-lang/tcl
+ dev-lang/swig )"
DEPEND="${RDEPEND}
virtual/libc"
+if has_version =dev-lang/tcl-8.3*; then
+ newdepend dev-lang/swig
+fi
+
+if has_version =dev-lang/tcl-8.4*; then
+ newdepend sys-devel/autoconf
+fi
+
S=${WORKDIR}/${P}.0
src_unpack() {
@@ -36,6 +47,11 @@ src_unpack() {
epatch ${FILESDIR}/${P}-makefile.patch
epatch ${FILESDIR}/${P}-fPIC.patch
+
+ if has_version =dev-lang/tcl-8.4*; then
+ epatch ${FILESDIR}/${P}-tcl_8_4.patch
+ autoconf || die
+ fi
}
src_compile() {
@@ -48,6 +64,8 @@ src_compile() {
`use_with pam` \
`use_with qt` \
`use_with speex` \
+ `use_with fftw` \
+ `use_with tcltk tcl` \
--enable-verbose \
--with-bdb \
--with-openssl \