summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/oasis/ChangeLog11
-rw-r--r--dev-ml/oasis/metadata.xml5
-rw-r--r--dev-ml/oasis/oasis-0.3.0_rc3.ebuild38
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/oasis/ChangeLog b/dev-ml/oasis/ChangeLog
new file mode 100644
index 000000000000..2d30b6058856
--- /dev/null
+++ b/dev-ml/oasis/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/oasis
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/oasis/ChangeLog,v 1.1 2012/03/28 12:45:00 aballier Exp $
+
+*oasis-0.3.0_rc3 (28 Mar 2012)
+
+ 28 Mar 2012; Alexis Ballier <aballier@gentoo.org> +oasis-0.3.0_rc3.ebuild,
+ +metadata.xml:
+ initial import, based on ebuild by Vladimir Ivanov in bug #355767 and
+ converted to oasis.eclass
+
diff --git a/dev-ml/oasis/metadata.xml b/dev-ml/oasis/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/oasis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/oasis/oasis-0.3.0_rc3.ebuild b/dev-ml/oasis/oasis-0.3.0_rc3.ebuild
new file mode 100644
index 000000000000..d2cf89f77126
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.3.0_rc3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/oasis/oasis-0.3.0_rc3.ebuild,v 1.1 2012/03/28 12:45:00 aballier Exp $
+
+EAPI=3
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/829/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-fileutils-0.4.2
+ dev-ml/batteries
+ dev-ml/pcre-ocaml
+ >=dev-ml/ocaml-data-notation-0.0.3
+ dev-ml/ocamlgraph"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ test? (
+ >=dev-ml/ounit-1.1.0
+ >=dev-ml/ocaml-expect-0.0.2
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.txt" "TODO.txt" "AUTHORS.txt" "CHANGES.txt" )