summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/ccache/ChangeLog7
-rw-r--r--dev-util/ccache/Manifest4
-rw-r--r--dev-util/ccache/ccache-2.3.ebuild69
-rw-r--r--dev-util/ccache/files/digest-ccache-2.31
4 files changed, 78 insertions, 3 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index 77a034cc56ef..26cc103c5e7a 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.21 2003/04/18 00:15:51 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.22 2003/09/29 19:41:18 mholzer Exp $
+
+*ccache-2.3 (29 Sep 2003)
+
+ 29 Sep 2003; Martin Holzer <mholzer@gentoo.org> ccache-2.3.ebuild:
+ Version bumped.
*ccache-2.2 (26 Feb 2003)
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index d5ed978acd63..737ce16f1aae 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -1,10 +1,10 @@
-MD5 bdd7830b5748160521a29b600fe1019c ChangeLog 3268
+MD5 22919cc45bbabb01b8233a4768abd8d4 ChangeLog 3384
MD5 5d69da54809d2eb42b58906cc20f4de8 ccache-1.9-r1.ebuild 1823
MD5 a703017f585f47441e2e399c7ad18be1 ccache-1.9-r2.ebuild 1626
MD5 ad6a03c5f52927d2fad39f24fc201bf0 ccache-2.1.1-r2.ebuild 2118
MD5 e9b8da93c11a27fafb3c2ea2f930e9e8 ccache-2.1.1.ebuild 1762
MD5 5e8e026be7c75dfebc5b773d5cbe3fb9 ccache-2.2.ebuild 2133
-MD5 5e8e026be7c75dfebc5b773d5cbe3fb9 ccache-2.3.ebuild 2133
+MD5 41f74e1f63a64ddd439fd6b59f1a611d ccache-2.3.ebuild 2160
MD5 3a5de45f5094320a0ce4eb5201506042 files/ccache-config 1554
MD5 7711e62922507dc2cf36bb4b4adcbe65 files/digest-ccache-1.9-r1 61
MD5 f55909c2215596543828d9a2f5aaaac1 files/digest-ccache-1.9-r2 60
diff --git a/dev-util/ccache/ccache-2.3.ebuild b/dev-util/ccache/ccache-2.3.ebuild
new file mode 100644
index 000000000000..e3fe3f1cc2a8
--- /dev/null
+++ b/dev-util/ccache/ccache-2.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.3.ebuild,v 1.1 2003/09/29 19:41:18 mholzer Exp $
+
+DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
+compiler to safely cache compilation output. When the same code is compiled
+again the cached output is used giving a significant speedup."
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+HOMEPAGE="http://ccache.samba.org/"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64"
+DEPEND="virtual/glibc \
+ >=sys-apps/portage-2.0.46-r11"
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.X+ installed.
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe ccache
+ doman ccache.1
+ dodoc COPYING README
+ dohtml web/*.html
+
+ diropts -m0755
+ dodir /usr/lib/ccache/bin
+ keepdir /usr/lib/ccache/bin
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/ccache-config
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_preinst() {
+ # Portage doesn't handle replacing a non-empty dir with a file!
+ [ -e /usr/bin/ccache ] && rm -rf /usr/bin/ccache
+ [ -e /usr/bin/ccache.backup ] && rm -rf /usr/bin/ccache.backup
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Scanning for compiler front-ends..."
+ /usr/bin/ccache-config --install-links
+ /usr/bin/ccache-config --install-links ${CHOST}
+ else
+ ewarn "Install is incomplete; you must run the following commands:"
+ ewarn " # ccache-config --install-links"
+ ewarn " # ccache-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/lib/ccache/bin to the beginning of your path, before /usr/bin."
+ einfo "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ einfo "no additional steps. If this is your first install of ccache, type"
+ einfo "something like this to set a maximum cache size of 2GB:"
+ einfo "# ccache -M 2G"
+}
diff --git a/dev-util/ccache/files/digest-ccache-2.3 b/dev-util/ccache/files/digest-ccache-2.3
new file mode 100644
index 000000000000..48ff2f2d8862
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-2.3
@@ -0,0 +1 @@
+MD5 5e4afc0b170bf282d1813aeaf3d577d2 ccache-2.3.tar.gz 84386