summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/espeakup/ChangeLog9
-rw-r--r--app-accessibility/espeakup/espeakup-0.51.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/app-accessibility/espeakup/ChangeLog b/app-accessibility/espeakup/ChangeLog
index e040cff2cb70..b130e72e3191 100644
--- a/app-accessibility/espeakup/ChangeLog
+++ b/app-accessibility/espeakup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/espeakup
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/ChangeLog,v 1.4 2008/10/23 13:29:36 williamh Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/ChangeLog,v 1.5 2009/02/11 15:10:15 williamh Exp $
+
+*espeakup-0.51 (11 Feb 2009)
+
+ 11 Feb 2009; William Hubbs <williamh@gentoo.org> +espeakup-0.51.ebuild:
+ Version bump.
23 Oct 2008; William Hubbs <williamh@gentoo.org> -espeakup-0.2.ebuild:
Removed old version.
diff --git a/app-accessibility/espeakup/espeakup-0.51.ebuild b/app-accessibility/espeakup/espeakup-0.51.ebuild
new file mode 100644
index 000000000000..af811dc6b650
--- /dev/null
+++ b/app-accessibility/espeakup/espeakup-0.51.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-0.51.ebuild,v 1.1 2009/02/11 15:10:15 williamh Exp $
+
+DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
+HOMEPAGE="http://www.linux-speakup.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-accessibility/espeak"
+RDEPEND="${DEPEND}
+ app-accessibility/speakup"
+
+src_compile() {
+ emake || die "Compile failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed."
+ dodoc README ToDo
+ newinitd "${FILESDIR}"/espeakup.rc espeakup
+}
+
+pkg_postinst() {
+ elog "To get espeakup to start automatically, it is currently recommended"
+ echo "that you add it to the default run level, by giving the following"
+ elog "command as root."
+ elog
+ elog "rc-update add espeakup default"
+}