summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/commons-el/ChangeLog9
-rw-r--r--dev-java/commons-el/commons-el-1.0-r1.ebuild49
-rw-r--r--dev-java/commons-el/files/digest-commons-el-1.02
-rw-r--r--dev-java/commons-el/files/digest-commons-el-1.0-r13
4 files changed, 61 insertions, 2 deletions
diff --git a/dev-java/commons-el/ChangeLog b/dev-java/commons-el/ChangeLog
index 7d687bc31884..b7149fd163de 100644
--- a/dev-java/commons-el/ChangeLog
+++ b/dev-java/commons-el/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-el
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/ChangeLog,v 1.12 2005/11/05 11:11:04 betelgeuse Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/ChangeLog,v 1.13 2006/07/04 20:40:28 nichoj Exp $
+
+*commons-el-1.0-r1 (04 Jul 2006)
+
+ 04 Jul 2006; Joshua Nichols <nichoj@gentoo.org> +commons-el-1.0-r1.ebuild:
+ Revision bump to support new Java system.
05 Nov 2005; Petteri Räty <betelgeuse@gentoo.org> commons-el-1.0.ebuild:
Fixed homepage reported in bug 111533.
diff --git a/dev-java/commons-el/commons-el-1.0-r1.ebuild b/dev-java/commons-el/commons-el-1.0-r1.ebuild
new file mode 100644
index 000000000000..1c1d72660c22
--- /dev/null
+++ b/dev-java/commons-el/commons-el-1.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0-r1.ebuild,v 1.1 2006/07/04 20:40:28 nichoj Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="EL is the JSP 2.0 Expression Language Interpreter from Apache."
+HOMEPAGE="http://jakarta.apache.org/commons/el/"
+SRC_URI="mirror://apache/jakarta/commons/el/source/${P}-src.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="source"
+COMMON_DEP="~dev-java/servletapi-2.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.5
+ ${COMMON_DEP}
+ source? ( app-arch/zip )"
+
+S=${WORKDIR}/${P}-src
+
+ant_src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv build.properties build.properties.old
+
+ echo "servlet-api.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)" >> build.properties
+ echo "jsp-api.jar=$(java-pkg_getjar servletapi-2.4 jsp-api.jar)" >> build.properties
+ echo "junit.jar = $(java-pkg_getjars junit)" >> build.properties
+ echo "servletapi.build.notrequired = true" >> build.properties
+ echo "jspapi.build.notrequired = true" >> build.properties
+
+ # Build.xml is broken, fix it
+ sed -i "s:../LICENSE:./LICENSE.txt:" build.xml || die "sed failed"
+}
+
+src_compile() {
+ eant jar
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar || die "Unable to install"
+ dodoc LICENSE.txt RELEASE-NOTES.txt
+ dohtml STATUS.html PROPOSAL.html
+
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-el/files/digest-commons-el-1.0 b/dev-java/commons-el/files/digest-commons-el-1.0
index 8c71540ed219..22867fcbbb5e 100644
--- a/dev-java/commons-el/files/digest-commons-el-1.0
+++ b/dev-java/commons-el/files/digest-commons-el-1.0
@@ -1 +1,3 @@
MD5 25038283a0b5f638db5e891295d20020 commons-el-1.0-src.tar.gz 64009
+RMD160 1f178aeb6aed1cd807573c3add6195a719a533e2 commons-el-1.0-src.tar.gz 64009
+SHA256 3c9bdded6073563aaaddc9ad7c7387b242dc03cc385381503026b665a366c2c6 commons-el-1.0-src.tar.gz 64009
diff --git a/dev-java/commons-el/files/digest-commons-el-1.0-r1 b/dev-java/commons-el/files/digest-commons-el-1.0-r1
new file mode 100644
index 000000000000..22867fcbbb5e
--- /dev/null
+++ b/dev-java/commons-el/files/digest-commons-el-1.0-r1
@@ -0,0 +1,3 @@
+MD5 25038283a0b5f638db5e891295d20020 commons-el-1.0-src.tar.gz 64009
+RMD160 1f178aeb6aed1cd807573c3add6195a719a533e2 commons-el-1.0-src.tar.gz 64009
+SHA256 3c9bdded6073563aaaddc9ad7c7387b242dc03cc385381503026b665a366c2c6 commons-el-1.0-src.tar.gz 64009