summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/muse/ChangeLog10
-rw-r--r--app-emacs/muse/Manifest5
-rw-r--r--app-emacs/muse/files/50muse-mode-gentoo.el14
-rw-r--r--app-emacs/muse/files/digest-muse-3.02.51
-rw-r--r--app-emacs/muse/metadata.xml30
-rw-r--r--app-emacs/muse/muse-3.02.5.ebuild42
6 files changed, 102 insertions, 0 deletions
diff --git a/app-emacs/muse/ChangeLog b/app-emacs/muse/ChangeLog
new file mode 100644
index 000000000000..626f5cef9ee7
--- /dev/null
+++ b/app-emacs/muse/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/muse
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/muse/ChangeLog,v 1.1 2006/01/11 18:16:00 wrobel Exp $
+
+*muse-3.02.5 (11 Jan 2006)
+
+ 11 Jan 2006; <wrobel@gentoo.org> +files/50muse-mode-gentoo.el,
+ +muse-3.02.5.ebuild:
+ Added the emacs muse-mode to portage.
+
diff --git a/app-emacs/muse/Manifest b/app-emacs/muse/Manifest
new file mode 100644
index 000000000000..9aead20e4eab
--- /dev/null
+++ b/app-emacs/muse/Manifest
@@ -0,0 +1,5 @@
+MD5 f260916963bb7bce2dd2ac1788267984 ChangeLog 272
+MD5 2629c00e1e62c3fcc06a1c64b066c403 files/50muse-mode-gentoo.el 242
+MD5 8cd9f78ba707e482747f01401f1979de files/digest-muse-3.02.5 63
+MD5 b8b307467564ef199fbd8dcb348590d6 metadata.xml 1409
+MD5 62134936f24d47d66679060d2449e940 muse-3.02.5.ebuild 921
diff --git a/app-emacs/muse/files/50muse-mode-gentoo.el b/app-emacs/muse/files/50muse-mode-gentoo.el
new file mode 100644
index 000000000000..b76111f264eb
--- /dev/null
+++ b/app-emacs/muse/files/50muse-mode-gentoo.el
@@ -0,0 +1,14 @@
+
+;;; muse-mode site-lisp configuration
+
+
+(require 'muse-mode) ; load authoring mode
+
+(require 'muse-project)
+
+(require 'muse-html) ; load publishing styles I use
+(require 'muse-latex)
+(require 'muse-texinfo)
+(require 'muse-docbook)
+
+
diff --git a/app-emacs/muse/files/digest-muse-3.02.5 b/app-emacs/muse/files/digest-muse-3.02.5
new file mode 100644
index 000000000000..52c283c8ebfb
--- /dev/null
+++ b/app-emacs/muse/files/digest-muse-3.02.5
@@ -0,0 +1 @@
+MD5 0ae64e3b1a366f784a00989fedbbcd7f muse-3.02.5.tar.gz 186816
diff --git a/app-emacs/muse/metadata.xml b/app-emacs/muse/metadata.xml
new file mode 100644
index 000000000000..135da40f247e
--- /dev/null
+++ b/app-emacs/muse/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+Emacs Muse is an authoring and publishing environment for Emacs. It
+simplifies the process of writing documents and publishing them to
+various output formats.
+
+Muse consists of two main parts: an enhanced text-mode for authoring
+documents and navigating within Muse projects, and a set of publishing
+styles for generating different kinds of output.
+
+This idea is not in any way new. Numerous systems exist - even one
+other for Emacs itself (Bhl Mode). What Muse adds to the picture is a
+more modular environment, with a rather simple core, in which "styles"
+are derived from to create new styles. Much of Muse's overall
+functionality is optional. For example, you can use the publisher
+without the major-mode, or the mode without doing any publishing; or
+if you don't load the Texinfo or LaTeX modules, those styles won't be
+available.
+
+The Muse codebase is a departure from emacs-wiki.el version 2.44. The
+code has been restructured and rewritten, especially its publishing
+functions. The focus in this revision is on the authoring and
+publishing aspects, and the "wikiness" has been removed as a default
+behavior (available as the optional module muse-wiki.el). CamelCase
+words are no longer special by default.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/muse/muse-3.02.5.ebuild b/app-emacs/muse/muse-3.02.5.ebuild
new file mode 100644
index 000000000000..e415d8ab5421
--- /dev/null
+++ b/app-emacs/muse/muse-3.02.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/muse/muse-3.02.5.ebuild,v 1.1 2006/01/11 18:16:00 wrobel Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Muse-mode is similar to EmacsWikiMode, but more focused on publishing to various formats."
+HOMEPAGE="http://www.mwolson.org/projects/MuseMode.html"
+SRC_URI="http://download.gna.org/muse-el/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50muse-mode-gentoo.el
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ make lisp
+}
+
+src_install() {
+ dodoc README
+ cp -r examples ${D}/usr/share/doc/${PF}/
+ mkdir -p ${D}/usr/share/${PF}/
+ cp -r contrib experimental scripts ${D}/usr/share/${PF}/
+ elisp-install ${PN} lisp/*.el lisp/*.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/muse-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}