summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/DirectFB/ChangeLog8
-rw-r--r--dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild125
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.4.9-libpng-1.5.patch4
3 files changed, 134 insertions, 3 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index fcc6aec05e0d..3bed4e0c87e0 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/DirectFB
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.119 2011/04/07 19:02:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.120 2011/06/08 19:13:28 vapier Exp $
+
+*DirectFB-1.4.9-r1 (08 Jun 2011)
+
+ 08 Jun 2011; Mike Frysinger <vapier@gentoo.org> +DirectFB-1.4.9-r1.ebuild,
+ files/DirectFB-1.4.9-libpng-1.5.patch:
+ Fix up typo in libpng patch point out by Victor Tseng #370607.
07 Apr 2011; Jeroen Roovers <jer@gentoo.org> DirectFB-1.4.9.ebuild:
Stable for HPPA (bug #360709).
diff --git a/dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild b/dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild
new file mode 100644
index 000000000000..4fc056ff43b7
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.4.9-r1.ebuild,v 1.1 2011/06/08 19:13:28 vapier Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+# Map Gentoo IUSE expand vars to DirectFB drivers
+# echo `sed -n '/Possible gfxdrivers are:/,/^$/{/Possible/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
+I_TO_D_intel="i810,i830"
+I_TO_D_mga="matrox"
+I_TO_D_r128="ati128"
+I_TO_D_s3="unichrome"
+I_TO_D_sis="sis315"
+I_TO_D_via="cle266"
+# cyber5k davinci ep9x gl omap pxa3xx sh772x
+IUSE_VIDEO_CARDS=" intel mach64 mga neomagic nsc nvidia r128 radeon s3 savage sis tdfx via vmware"
+IUV=${IUSE_VIDEO_CARDS// / video_cards_}
+# echo `sed -n '/Possible inputdrivers are:/,/^$/{/\(Possible\|^input\)/d;s:\[ *::;s:\].*::;s:,::g;p}' configure.in`
+I_TO_D_elo2300="elo-input"
+I_TO_D_evdev="linuxinput"
+I_TO_D_mouse="ps2mouse serialmouse"
+# dbox2remote dreamboxremote gunze h3600_ts penmount sonypijogdial ucb1x00 wm97xx zytronic
+IUSE_INPUT_DEVICES=" dynapro elo2300 evdev joystick keyboard lirc mouse mutouch tslib"
+IUD=${IUSE_INPUT_DEVICES// / input_devices_}
+
+DESCRIPTION="Thin library on top of the Linux framebuffer devices"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://directfb.org/downloads/Core/${PN}-${PV:0:3}/${P}.tar.gz
+ http://directfb.org/downloads/Old/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
+IUSE="debug doc fbcon gif jpeg mmx png sdl sse static-libs sysfs truetype v4l v4l2 X zlib ${IUV} ${IUD}"
+
+RDEPEND="sdl? ( media-libs/libsdl )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( virtual/jpeg )
+ sysfs? ( sys-fs/sysfsutils )
+ zlib? ( sys-libs/zlib )
+ truetype? ( >=media-libs/freetype-2.0.1 )
+ X? ( x11-libs/libXext x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xextproto x11-proto/xproto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.2.7-CFLAGS.patch \
+ "${FILESDIR}"/${PN}-1.2.0-headers.patch \
+ "${FILESDIR}"/${PN}-1.1.1-pkgconfig.patch \
+ "${FILESDIR}"/${PN}-1.4.9-libpng-1.5.patch
+
+ # the media subdir uses sqrt(), so make sure it links in -lm
+ sed -i \
+ -e '/libdirectfb_media_la_LIBADD/s:$: -lm:' \
+ src/media/Makefile.in || die
+
+ # Avoid invoking `ld` directly #300779
+ find . -name Makefile.in -exec sed -i \
+ '/[$](LD)/s:$(LD) -o $@ -r:$(CC) $(LDFLAGS) $(CFLAGS) -Wl,-r -nostdlib -o $@:' {} +
+}
+
+driver_list() {
+ local pfx=$1
+ local dev devs map
+ shift
+ for dev in "$@" ; do
+ use ${pfx}_${dev} || continue
+ map="I_TO_D_${dev}"
+ devs=${devs:+${devs},}${!map:-${dev}}
+ done
+ echo ${devs:-none}
+}
+
+src_configure() {
+ local sdlconf="--disable-sdl"
+ if use sdl ; then
+ # since SDL can link against DirectFB and trigger a
+ # dependency loop, only link against SDL if it isn't
+ # broken #61592
+ echo 'int main(){}' > sdl-test.c
+ $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
+ && sdlconf="--enable-sdl" \
+ || ewarn "Disabling SDL since libSDL.so is broken"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable X x11) \
+ $(use_enable fbcon fbdev) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable gif) \
+ $(use_enable truetype freetype) \
+ $(use_enable debug) \
+ $(use_enable sysfs) \
+ $(use_enable zlib) \
+ $(use_enable v4l video4linux) \
+ $(use_enable v4l2 video4linux2) \
+ ${sdlconf} \
+ --with-gfxdrivers="$(driver_list video_cards ${IUSE_VIDEO_CARDS})" \
+ --with-inputdrivers="$(driver_list input_devices ${IUSE_INPUT_DEVICES})" \
+ --disable-vnc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ ewarn "Each DirectFB update breaks DirectFB related applications."
+ ewarn "Please run \"revdep-rebuild\" which can be"
+ ewarn "found by emerging the package 'gentoolkit'."
+ ewarn
+ ewarn "If you have an ALPS touchpad, then you might get your mouse"
+ ewarn "unexpectedly set in absolute mode in all DirectFB applications."
+ ewarn "This can be fixed by removing linuxinput from INPUT_DEVICES."
+}
diff --git a/dev-libs/DirectFB/files/DirectFB-1.4.9-libpng-1.5.patch b/dev-libs/DirectFB/files/DirectFB-1.4.9-libpng-1.5.patch
index a5df1caaffe9..e428afbaf7c3 100644
--- a/dev-libs/DirectFB/files/DirectFB-1.4.9-libpng-1.5.patch
+++ b/dev-libs/DirectFB/files/DirectFB-1.4.9-libpng-1.5.patch
@@ -17,7 +17,7 @@ index 6d65ea3..7d82c5c 100644
goto error;
- if (setjmp( data->png_ptr->jmpbuf )) {
-+ if (png_jmpbuf( data->png_ptr )) {
++ if (setjmp( png_jmpbuf( data->png_ptr ))) {
D_ERROR( "ImageProvider/PNG: Error reading header!\n" );
goto error;
}
@@ -26,7 +26,7 @@ index 6d65ea3..7d82c5c 100644
}
- if (setjmp( data->png_ptr->jmpbuf )) {
-+ if (png_jmpbuf( data->png_ptr )) {
++ if (setjmp( png_jmpbuf( data->png_ptr ))) {
D_ERROR( "ImageProvider/PNG: Error during decoding!\n" );
if (data->stage < STAGE_IMAGE)