summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/tikiwiki/ChangeLog7
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.63
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.6.ebuild83
3 files changed, 92 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 4b963f407797..e6a1faf3ee81 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.34 2006/09/15 18:34:02 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.35 2006/11/08 04:08:48 rl03 Exp $
+
+*tikiwiki-1.9.6 (08 Nov 2006)
+
+ 08 Nov 2006; Renat Lumpau <rl03@gentoo.org> +tikiwiki-1.9.6.ebuild:
+ Version bump, security bug #153820.
15 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org>
tikiwiki-1.9.5.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.6 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.6
new file mode 100644
index 000000000000..101966d1c137
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.6
@@ -0,0 +1,3 @@
+MD5 4840b3b0504b46f2454d3fbedc6691bb tikiwiki-1.9.6.tar.bz2 6016006
+RMD160 744f086889e3b379cb2b5fdb27bd75fa5936bd51 tikiwiki-1.9.6.tar.bz2 6016006
+SHA256 1231c2ea15e9dc47b94f19a269fbf6f6068d2e84c532cd6d0f78ec98e6119771 tikiwiki-1.9.6.tar.bz2 6016006
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.6.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.6.ebuild
new file mode 100644
index 000000000000..f646598bb67f
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.6.ebuild,v 1.1 2006/11/08 04:08:48 rl03 Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/php
+ mysql? ( >=dev-db/mysql-4 )
+ postgres? ( dev-db/postgresql )
+ graphviz? ( media-gfx/graphviz )
+"
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* ${D}/${MY_HTDOCSDIR}
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned ${MY_HTDOCSDIR}
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned ${MY_HTDOCSDIR}/${DIRENTRY}
+ done
+ done
+ webapp_serverowned ${MY_HTDOCSDIR}/tiki-install.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}
+
+pkg_config() {
+ elog "Type in your MySQL root password to create an empty tiki database:"
+ mysqladmin -u root -p create tikiwiki
+}
+
+pkg_postinst() {
+ elog "To setup a MySQL database, run:"
+ elog "\"emerge --config =${PF}\""
+ elog "If you are using PostgreSQL, consult your documentation"
+ webapp_pkg_postinst
+}