summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/xindy/ChangeLog8
-rw-r--r--app-text/xindy/files/xindy-2.4-locale.patch22
-rw-r--r--app-text/xindy/xindy-2.4.ebuild5
3 files changed, 31 insertions, 4 deletions
diff --git a/app-text/xindy/ChangeLog b/app-text/xindy/ChangeLog
index b9914424ed07..418d46ace233 100644
--- a/app-text/xindy/ChangeLog
+++ b/app-text/xindy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/xindy
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/ChangeLog,v 1.11 2010/09/29 17:47:22 radhermit Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/ChangeLog,v 1.12 2011/02/09 09:02:34 radhermit Exp $
+
+ 09 Feb 2011; Tim Harder <radhermit@gentoo.org> xindy-2.4.ebuild,
+ +files/xindy-2.4-locale.patch:
+ Apply patch for a locale related compile failure (bug #340008).
*xindy-2.4 (29 Sep 2010)
diff --git a/app-text/xindy/files/xindy-2.4-locale.patch b/app-text/xindy/files/xindy-2.4-locale.patch
new file mode 100644
index 000000000000..c2edccc4bef6
--- /dev/null
+++ b/app-text/xindy/files/xindy-2.4-locale.patch
@@ -0,0 +1,22 @@
+--- xindy-2.4.orig/src/Makefile.am
++++ xindy-2.4/src/Makefile.am
+@@ -41,7 +41,7 @@
+ DEFAULTS = defaults.xdy
+ DUMP_XINDY = dump-xindy.lsp
+ MEMFILE = xindy.mem
+-CLISP = @CLISP@ -q -E iso-8859-1
++CLISP = @CLISP@ -q
+
+ xindy.mem: $(DEFAULTS) $(FAS) $(DUMP_XINDY)
+ rm -f $(MEMFILE)
+--- xindy-2.4.orig/user-commands/xindy.in
++++ xindy-2.4/user-commands/xindy.in
+@@ -777,7 +777,7 @@
+ sub call_xindy ( $$ ) {
+ my ($mem_file, $xindy_exp) = @_;
+
+- my @command = ($clisp, '-M', $mem_file, '-E', 'iso-8859-1');
++ my @command = ($clisp, '-M', $mem_file);
+ if ( $interactive ) {
+ print "Proposed xindy expression:\n\n$xindy_exp\n" unless $quiet;
+ } else {
diff --git a/app-text/xindy/xindy-2.4.ebuild b/app-text/xindy/xindy-2.4.ebuild
index 0a1af51f2596..330b1f749666 100644
--- a/app-text/xindy/xindy-2.4.ebuild
+++ b/app-text/xindy/xindy-2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/xindy-2.4.ebuild,v 1.1 2010/09/29 17:47:22 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/xindy-2.4.ebuild,v 1.2 2011/02/09 09:02:34 radhermit Exp $
EAPI=3
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-locale.patch
eautoreconf
}