summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libnet/ChangeLog10
-rw-r--r--net-libs/libnet/Manifest6
-rw-r--r--net-libs/libnet/files/digest-libnet-1.0.2a-r21
-rw-r--r--net-libs/libnet/libnet-1.0.2a-r2.ebuild36
-rw-r--r--net-libs/libnet/libnet-1.0.2a-r3.ebuild4
5 files changed, 51 insertions, 6 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index 26822a533830..c190412eb084 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libnet
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.24 2003/11/30 05:25:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.25 2003/12/16 18:52:26 weeve Exp $
+
+*libnet-1.0.2a-r2 (16 Dec 2003)
+
+ 16 Dec 2003; Jason Wever <weeve@gentoo.org> libnet-1.0.2a-r2.ebuild,
+ libnet-1.0.2a-r3.ebuild:
+ Marked libnet-1.0.2a-r3.ebuild BACK to unstable and brought
+ libnet-1.0.2a-r2.ebuild back to compensate for the fact that newer versions of
+ snort have issues on sparc.
*libnet-1.1.1 (30 Nov 2003)
diff --git a/net-libs/libnet/Manifest b/net-libs/libnet/Manifest
index de46ea5b43cf..1068976eefd7 100644
--- a/net-libs/libnet/Manifest
+++ b/net-libs/libnet/Manifest
@@ -1,8 +1,8 @@
-MD5 9494e217541baf383e17bcfe69c531e7 ChangeLog 4077
-MD5 c91054e502b827c26d68126a8139b682 libnet-1.0.2a-r3.ebuild 1505
+MD5 157983274b55d8f39c2820e08918d495 ChangeLog 4076
+MD5 f099bd858e9d032dc6da8b0a51f3161e libnet-1.0.2a-r3.ebuild 1504
MD5 7bfa481207154b25a5d8ac7fbfcc47b8 libnet-1.1.0-r3.ebuild 842
MD5 942331b9a961ca7b53ad3d90870da8e2 libnet-1.1.1.ebuild 742
-MD5 fccb9f5592496f08f7158927983cdda5 libnet-1.0.2a-r2.ebuild 1024
+MD5 77e41ecc1d2025135eecbc4d9776faf0 libnet-1.0.2a-r2.ebuild 1011
MD5 03222434915e5cdf87199c89f16fd09e files/1.0.2a-slot.patch 4889
MD5 d43e05bf93cf1aa86c23be9c1ab2f009 files/digest-libnet-1.0.2a-r3 58
MD5 dee8fc87567b0aca2bfdc055d60a5151 files/digest-libnet-1.1.0-r3 64
diff --git a/net-libs/libnet/files/digest-libnet-1.0.2a-r2 b/net-libs/libnet/files/digest-libnet-1.0.2a-r2
new file mode 100644
index 000000000000..b7debea8cbbc
--- /dev/null
+++ b/net-libs/libnet/files/digest-libnet-1.0.2a-r2
@@ -0,0 +1 @@
+MD5 ddf53f0f484184390e8c2a1bd0853667 libnet.tar.gz 140191
diff --git a/net-libs/libnet/libnet-1.0.2a-r2.ebuild b/net-libs/libnet/libnet-1.0.2a-r2.ebuild
new file mode 100644
index 000000000000..358a5e5098bb
--- /dev/null
+++ b/net-libs/libnet/libnet-1.0.2a-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.0.2a-r2.ebuild,v 1.13 2003/12/16 18:52:26 weeve Exp $
+
+S=${WORKDIR}/Libnet-1.0.2a
+DESCRIPTION="library to provide an API for commonly used low-level network
+functions (mainly packet injection). Used by packet scrubbers and the like,
+not to be confused with the perl libnet"
+SRC_URI="http://www.packetfactory.net/${PN}/dist/${PN}.tar.gz"
+HOMEPAGE="http://www.packetfactory.net/${PN}/"
+
+DEPEND=""
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="sparc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/libnet-gcc33-fix
+}
+
+src_compile() {
+ econf || die
+ emake CFLAGS="${CFLAGS}" || die "Failed to compile"
+}
+
+src_install () {
+ einstall \
+ MAN_PREFIX=${D}/usr/share/man/man3 || die
+
+ dodoc VERSION doc/{README,TODO*,CHANGELOG*,COPYING}
+ newdoc README README.1st
+ docinto example ; dodoc example/libnet*
+ docinto Ancillary ; dodoc doc/Ancillary/*
+}
diff --git a/net-libs/libnet/libnet-1.0.2a-r3.ebuild b/net-libs/libnet/libnet-1.0.2a-r3.ebuild
index 323aa9f41d19..b7ab3065e574 100644
--- a/net-libs/libnet/libnet-1.0.2a-r3.ebuild
+++ b/net-libs/libnet/libnet-1.0.2a-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.0.2a-r3.ebuild,v 1.6 2003/11/10 01:57:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.0.2a-r3.ebuild,v 1.7 2003/12/16 18:52:26 weeve Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.packetfactory.net/libnet/dist/${PN}.tar.gz"
LICENSE="LGPL-2"
SLOT="1.0"
-KEYWORDS="x86 ppc sparc arm alpha amd64"
+KEYWORDS="x86 ppc ~sparc arm alpha amd64"
S=${WORKDIR}/Libnet-${PV}