summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/motion/ChangeLog6
-rw-r--r--media-video/motion/files/motion.init-r129
-rw-r--r--media-video/motion/files/motion.initd39
-rw-r--r--media-video/motion/motion-3.2.11.1.ebuild70
-rw-r--r--media-video/motion/motion-3.2.12.ebuild64
5 files changed, 5 insertions, 203 deletions
diff --git a/media-video/motion/ChangeLog b/media-video/motion/ChangeLog
index 0f26d689d3b4..05533192d539 100644
--- a/media-video/motion/ChangeLog
+++ b/media-video/motion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/motion
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.35 2011/10/06 08:06:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.36 2011/11/14 03:46:46 ssuominen Exp $
+
+ 14 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> -motion-3.2.11.1.ebuild,
+ -motion-3.2.12.ebuild, -files/motion.init-r1, -files/motion.initd:
+ old
06 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> motion-3.2.12-r1.ebuild:
amd64 stable wrt #385359
diff --git a/media-video/motion/files/motion.init-r1 b/media-video/motion/files/motion.init-r1
deleted file mode 100644
index a45d3ae95501..000000000000
--- a/media-video/motion/files/motion.init-r1
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/files/motion.init-r1,v 1.2 2011/05/19 18:51:26 ssuominen Exp $
-
-opts="${opts} reload"
-
-depend() {
- need modules
- after mysql
-}
-
-start() {
- ebegin "Starting motion detection"
- start-stop-daemon --start -c ${MOTION_USER} -g ${MOTION_GROUP} --quiet --exec /usr/bin/motion
- eend $?
-}
-
-stop() {
- ebegin "Stopping motion detection"
- start-stop-daemon --stop --quiet --exec /usr/bin/motion
- eend $?
-}
-
-reload() {
- ebegin "Reloading motion detection configuration"
- start-stop-daemon --stop --signal HUP --exec /usr/bin/motion
- eend $?
-}
diff --git a/media-video/motion/files/motion.initd b/media-video/motion/files/motion.initd
deleted file mode 100644
index de13ed9243e6..000000000000
--- a/media-video/motion/files/motion.initd
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/files/motion.initd,v 1.1 2011/05/19 18:50:35 ssuominen Exp $
-
-opts="${opts} reload"
-
-_create_motion_run_dir() {
- local dir="/var/run/motion"
- if ! [ -d "$dir" ]; then
- mkdir -p -m750 "$dir"
- chown ${MOTION_USER}:${MOTION_GROUP} "$dir"
- fi
-}
-
-depend() {
- need modules
- after mysql
-}
-
-start() {
- _create_motion_run_dir
-
- ebegin "Starting motion detection"
- start-stop-daemon --start -c ${MOTION_USER} -g ${MOTION_GROUP} --quiet --exec /usr/bin/motion
- eend $?
-}
-
-stop() {
- ebegin "Stopping motion detection"
- start-stop-daemon --stop --quiet --exec /usr/bin/motion
- eend $?
-}
-
-reload() {
- ebegin "Reloading motion detection configuration"
- start-stop-daemon --stop --signal HUP --exec /usr/bin/motion
- eend $?
-}
diff --git a/media-video/motion/motion-3.2.11.1.ebuild b/media-video/motion/motion-3.2.11.1.ebuild
deleted file mode 100644
index 098df2dd0d3c..000000000000
--- a/media-video/motion/motion-3.2.11.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.11.1.ebuild,v 1.8 2011/05/19 18:50:35 ssuominen Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Motion is a video motion detector with tracking-support for webcams."
-HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ppc ~x86"
-IUSE="ffmpeg mysql postgres v4l"
-
-RDEPEND="sys-libs/zlib
- virtual/jpeg
- ffmpeg? ( virtual/ffmpeg )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )"
-DEPEND="${RDEPEND}
- v4l? ( virtual/os-headers )"
-
-pkg_setup() {
- enewuser motion -1 -1 -1 video
-}
-
-src_prepare() {
- sed -i \
- -e 's:jpeg_mem_dest:_jpeg_mem_dest:g' \
- picture.c || die
-}
-
-src_configure() {
- econf \
- $(use_with v4l) \
- $(use_with ffmpeg) \
- $(use_with mysql) \
- $(use_with postgres pgsql) \
- --without-optimizecpu
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- newinitd "${FILESDIR}"/motion.init-r1 motion
- newconfd "${FILESDIR}"/motion.confd motion
-
- # Create correct dir for motion.pid
- dodir /var/run/motion
- fowners motion:video /var/run/motion
- fperms 750 /var/run/motion
- keepdir /var/run/motion
-
- # Rename configuration file.
- mv "${D}"/etc/motion-dist.conf "${D}"/etc/motion.conf
-
- # Remove dummy documentation and install it using ebuild functions.
- rm -rf "${D}"/usr/share/doc/${P}
- dodoc CHANGELOG CODE_STANDARD CREDITS FAQ README README.FreeBSD *.conf
- dohtml *.html
-}
-
-pkg_postinst() {
- elog "You need to setup /etc/motion.conf before running"
- elog "motion for the first time. You can install motion"
- elog "detection as a service, use:"
- elog "rc-update add motion default"
-}
diff --git a/media-video/motion/motion-3.2.12.ebuild b/media-video/motion/motion-3.2.12.ebuild
deleted file mode 100644
index 25331ae99db5..000000000000
--- a/media-video/motion/motion-3.2.12.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.12.ebuild,v 1.1 2011/05/19 18:50:35 ssuominen Exp $
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="A software motion detector"
-HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
-IUSE="ffmpeg mysql postgres v4l"
-
-RDEPEND="sys-libs/zlib
- virtual/jpeg
- ffmpeg? ( virtual/ffmpeg )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )"
-DEPEND="${RDEPEND}
- v4l? ( virtual/os-headers )"
-
-pkg_setup() {
- enewuser motion -1 -1 -1 video
-}
-
-src_configure() {
- local hack
- has_version '>=sys-kernel/linux-headers-2.6.38' && hack="--without-v4l" #361509
-
- econf \
- $(use_with v4l) \
- $(use_with ffmpeg) \
- $(use_with mysql) \
- $(use_with postgres pgsql) \
- --without-optimizecpu \
- ${hack}
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- DOC='CHANGELOG CODE_STANDARD CREDITS FAQ README' \
- docdir=/usr/share/doc/${PF} \
- EXAMPLES='thread*.conf' \
- examplesdir=/usr/share/doc/${PF}/examples \
- install
-
- dohtml *.html
-
- newinitd "${FILESDIR}"/motion.initd motion
- newconfd "${FILESDIR}"/motion.confd motion
-
- mv -vf "${D}"/etc/motion{-dist,}.conf || die
-}
-
-pkg_postinst() {
- elog "You need to setup /etc/motion.conf before running"
- elog "motion for the first time."
- elog "You can install motion detection as a service, use:"
- elog "rc-update add motion default"
-}