summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-apps/xfs/ChangeLog7
-rw-r--r--x11-apps/xfs/files/digest-xfs-0.99.31
-rw-r--r--x11-apps/xfs/xfs-0.99.3.ebuild43
-rw-r--r--x11-apps/xfwp/ChangeLog8
-rw-r--r--x11-apps/xfwp/files/digest-xfwp-0.99.21
-rw-r--r--x11-apps/xfwp/xfwp-0.99.2.ebuild15
-rw-r--r--x11-apps/xgamma/ChangeLog8
-rw-r--r--x11-apps/xgamma/files/digest-xgamma-0.99.21
-rw-r--r--x11-apps/xgamma/xgamma-0.99.2.ebuild13
-rw-r--r--x11-apps/xgc/ChangeLog7
-rw-r--r--x11-apps/xgc/files/digest-xgc-0.99.21
-rw-r--r--x11-apps/xgc/xgc-0.99.2.ebuild22
-rw-r--r--x11-apps/xhost/ChangeLog8
-rw-r--r--x11-apps/xhost/files/digest-xhost-0.99.31
-rw-r--r--x11-apps/xhost/xhost-0.99.3.ebuild17
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/files/digest-xinit-0.99.41
-rw-r--r--x11-apps/xinit/files/gentoo-startx-customization-0.99.4.patch154
-rw-r--r--x11-apps/xinit/xinit-0.99.4.ebuild41
-rw-r--r--x11-apps/xkbcomp/ChangeLog8
-rw-r--r--x11-apps/xkbcomp/files/digest-xkbcomp-0.99.21
-rw-r--r--x11-apps/xkbcomp/xkbcomp-0.99.2.ebuild21
-rw-r--r--x11-apps/xkbevd/ChangeLog8
-rw-r--r--x11-apps/xkbevd/files/digest-xkbevd-0.99.31
-rw-r--r--x11-apps/xkbevd/xkbevd-0.99.3.ebuild13
-rw-r--r--x11-apps/xkbprint/ChangeLog8
-rw-r--r--x11-apps/xkbprint/files/digest-xkbprint-0.99.21
-rw-r--r--x11-apps/xkbprint/xkbprint-0.99.2.ebuild13
-rw-r--r--x11-apps/xkbutils/ChangeLog8
-rw-r--r--x11-apps/xkbutils/files/digest-xkbutils-0.99.21
-rw-r--r--x11-apps/xkbutils/xkbutils-0.99.2.ebuild23
-rw-r--r--x11-apps/xkill/ChangeLog8
-rw-r--r--x11-apps/xkill/files/digest-xkill-0.99.21
-rw-r--r--x11-apps/xkill/xkill-0.99.2.ebuild14
34 files changed, 475 insertions, 11 deletions
diff --git a/x11-apps/xfs/ChangeLog b/x11-apps/xfs/ChangeLog
index 25ac39e17197..2fc074660493 100644
--- a/x11-apps/xfs/ChangeLog
+++ b/x11-apps/xfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xfs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.10 2005/11/11 19:55:14 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.11 2005/12/04 22:04:25 joshuabaergen Exp $
+
+*xfs-0.99.3 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xfs-0.99.3.ebuild:
+ Bump for 7.0RC3.
*xfs-0.99.2 (11 Nov 2005)
diff --git a/x11-apps/xfs/files/digest-xfs-0.99.3 b/x11-apps/xfs/files/digest-xfs-0.99.3
new file mode 100644
index 000000000000..a2d4a5436564
--- /dev/null
+++ b/x11-apps/xfs/files/digest-xfs-0.99.3
@@ -0,0 +1 @@
+MD5 d2995737ceddc99d2f62b2cf835e92ff xfs-0.99.3.tar.bz2 139886
diff --git a/x11-apps/xfs/xfs-0.99.3.ebuild b/x11-apps/xfs/xfs-0.99.3.ebuild
new file mode 100644
index 000000000000..fd865d03f3e8
--- /dev/null
+++ b/x11-apps/xfs/xfs-0.99.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/xfs-0.99.3.ebuild,v 1.1 2005/12/04 22:04:25 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfs application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+IUSE="ipv6"
+RDEPEND="x11-libs/libFS
+ x11-libs/libXfont"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --libdir=/etc"
+
+pkg_setup() {
+ enewgroup xfs 33
+ enewuser xfs 33 -1 /etc/X11/fs xfs
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^configdir =.*:configdir = \$(sysconfdir)/X11/fs:g" \
+ ${S}/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+
+ insinto /etc/X11/fs
+ newins ${FILESDIR}/xfs.config config
+ newinitd ${FILESDIR}/xfs.start xfs
+ newconfd ${FILESDIR}/xfs.conf.d xfs
+}
diff --git a/x11-apps/xfwp/ChangeLog b/x11-apps/xfwp/ChangeLog
index 1cf7f14a95de..681d21b2bc09 100644
--- a/x11-apps/xfwp/ChangeLog
+++ b/x11-apps/xfwp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xfwp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfwp/ChangeLog,v 1.4 2005/10/20 00:45:23 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfwp/ChangeLog,v 1.5 2005/12/04 22:04:53 joshuabaergen Exp $
+
+*xfwp-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xfwp-0.99.2.ebuild:
+ Bump for 7.0RC3.
*xfwp-0.99.1 (20 Oct 2005)
diff --git a/x11-apps/xfwp/files/digest-xfwp-0.99.2 b/x11-apps/xfwp/files/digest-xfwp-0.99.2
new file mode 100644
index 000000000000..788e1a750543
--- /dev/null
+++ b/x11-apps/xfwp/files/digest-xfwp-0.99.2
@@ -0,0 +1 @@
+MD5 423b0aa95d5c0d6e1dc62a25c9455ab4 xfwp-0.99.2.tar.bz2 103315
diff --git a/x11-apps/xfwp/xfwp-0.99.2.ebuild b/x11-apps/xfwp/xfwp-0.99.2.ebuild
new file mode 100644
index 000000000000..cb342cb75c82
--- /dev/null
+++ b/x11-apps/xfwp/xfwp-0.99.2.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfwp/xfwp-0.99.2.ebuild,v 1.1 2005/12/04 22:04:53 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfwp application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE"
+DEPEND="${RDEPEND}
+ x11-proto/xproxymanagementprotocol"
diff --git a/x11-apps/xgamma/ChangeLog b/x11-apps/xgamma/ChangeLog
index 0b08cf9b6d29..0229dd542dfe 100644
--- a/x11-apps/xgamma/ChangeLog
+++ b/x11-apps/xgamma/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xgamma
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgamma/ChangeLog,v 1.5 2005/11/26 09:38:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgamma/ChangeLog,v 1.6 2005/12/04 22:05:19 joshuabaergen Exp $
+
+*xgamma-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xgamma-0.99.2.ebuild:
+ Bump for 7.0RC3.
26 Nov 2005; Simon Stelling <blubb@gentoo.org> xgamma-0.99.1.ebuild:
added ~amd64 keyword
diff --git a/x11-apps/xgamma/files/digest-xgamma-0.99.2 b/x11-apps/xgamma/files/digest-xgamma-0.99.2
new file mode 100644
index 000000000000..ed0357eda88b
--- /dev/null
+++ b/x11-apps/xgamma/files/digest-xgamma-0.99.2
@@ -0,0 +1 @@
+MD5 d2fa330b2f3f66564d31f6eb8b38cc1b xgamma-0.99.2.tar.bz2 73825
diff --git a/x11-apps/xgamma/xgamma-0.99.2.ebuild b/x11-apps/xgamma/xgamma-0.99.2.ebuild
new file mode 100644
index 000000000000..9b633d3a9e2f
--- /dev/null
+++ b/x11-apps/xgamma/xgamma-0.99.2.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgamma/xgamma-0.99.2.ebuild,v 1.1 2005/12/04 22:05:19 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xgamma application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xgc/ChangeLog b/x11-apps/xgc/ChangeLog
index a6925ea7973c..f23ceb859389 100644
--- a/x11-apps/xgc/ChangeLog
+++ b/x11-apps/xgc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xgc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgc/ChangeLog,v 1.4 2005/10/20 00:45:23 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgc/ChangeLog,v 1.5 2005/12/04 22:05:46 joshuabaergen Exp $
+
+*xgc-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xgc-0.99.2.ebuild:
+ Bump for 7.0RC3.
*xgc-0.99.1 (20 Oct 2005)
diff --git a/x11-apps/xgc/files/digest-xgc-0.99.2 b/x11-apps/xgc/files/digest-xgc-0.99.2
new file mode 100644
index 000000000000..aea25c32898f
--- /dev/null
+++ b/x11-apps/xgc/files/digest-xgc-0.99.2
@@ -0,0 +1 @@
+MD5 247841f01b9196d7ba0dae5f9e941a26 xgc-0.99.2.tar.bz2 127131
diff --git a/x11-apps/xgc/xgc-0.99.2.ebuild b/x11-apps/xgc/xgc-0.99.2.ebuild
new file mode 100644
index 000000000000..cab08e7fd2a2
--- /dev/null
+++ b/x11-apps/xgc/xgc-0.99.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xgc/xgc-0.99.2.ebuild,v 1.1 2005/12/04 22:05:46 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xgc application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
diff --git a/x11-apps/xhost/ChangeLog b/x11-apps/xhost/ChangeLog
index 3e13701305ba..876f1f56bd3f 100644
--- a/x11-apps/xhost/ChangeLog
+++ b/x11-apps/xhost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xhost
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xhost/ChangeLog,v 1.11 2005/11/11 19:55:41 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xhost/ChangeLog,v 1.12 2005/12/04 22:06:19 joshuabaergen Exp $
+
+*xhost-0.99.3 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xhost-0.99.3.ebuild:
+ Bump for 7.0RC3.
*xhost-0.99.2 (11 Nov 2005)
diff --git a/x11-apps/xhost/files/digest-xhost-0.99.3 b/x11-apps/xhost/files/digest-xhost-0.99.3
new file mode 100644
index 000000000000..a99132459e01
--- /dev/null
+++ b/x11-apps/xhost/files/digest-xhost-0.99.3
@@ -0,0 +1 @@
+MD5 57dbd8de9bae4659e9e7ad8b8ad13d40 xhost-0.99.3.tar.bz2 84683
diff --git a/x11-apps/xhost/xhost-0.99.3.ebuild b/x11-apps/xhost/xhost-0.99.3.ebuild
new file mode 100644
index 000000000000..6417150e3019
--- /dev/null
+++ b/x11-apps/xhost/xhost-0.99.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xhost/xhost-0.99.3.ebuild,v 1.1 2005/12/04 22:06:19 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xhost application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+IUSE="ipv6"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)"
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 25925b667642..1d88e08dc30f 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.24 2005/11/11 19:38:36 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.25 2005/12/04 22:06:52 joshuabaergen Exp $
+
+*xinit-0.99.4 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/gentoo-startx-customization-0.99.4.patch, +xinit-0.99.4.ebuild:
+ Bump for 7.0RC3.
*xinit-0.99.3 (11 Nov 2005)
diff --git a/x11-apps/xinit/files/digest-xinit-0.99.4 b/x11-apps/xinit/files/digest-xinit-0.99.4
new file mode 100644
index 000000000000..f746745234ee
--- /dev/null
+++ b/x11-apps/xinit/files/digest-xinit-0.99.4
@@ -0,0 +1 @@
+MD5 bb443db632476d4b2bd42e1558004267 xinit-0.99.4.tar.bz2 91094
diff --git a/x11-apps/xinit/files/gentoo-startx-customization-0.99.4.patch b/x11-apps/xinit/files/gentoo-startx-customization-0.99.4.patch
new file mode 100644
index 000000000000..2544fb0f4414
--- /dev/null
+++ b/x11-apps/xinit/files/gentoo-startx-customization-0.99.4.patch
@@ -0,0 +1,154 @@
+--- startx.cpp.old 2005-11-11 12:29:49.244146352 -0700
++++ startx.cpp 2005-11-11 12:34:11.169327672 -0700
+@@ -64,8 +64,6 @@
+
+ userserverrc=$HOME/.xserverrc
+ sysserverrc=XINITDIR/xserverrc
+-defaultclient=XTERM
+-defaultserver=XSERVER
+ defaultclientargs=""
+ defaultserverargs="-nolisten tcp -br"
+ clientargs=""
+@@ -107,60 +105,41 @@
+ whoseargs="client"
+ while [ x"$1" != x ]; do
+ case "$1" in
+- XCOMM '' required to prevent cpp from treating "/*" as a C comment.
+- /''*|\./''*)
+- if [ "$whoseargs" = "client" ]; then
+- if [ x"$clientargs" = x ]; then
+- client="$1"
+- else
+- clientargs="$clientargs $1"
+- fi
+- else
+- if [ x"$serverargs" = x ]; then
+- server="$1"
+- else
+- serverargs="$serverargs $1"
+- fi
+- fi
+- ;;
+- --)
+- whoseargs="server"
+- ;;
+- *)
+- if [ "$whoseargs" = "client" ]; then
+- clientargs="$clientargs $1"
+- else
+- XCOMM display must be the FIRST server argument
+- if [ x"$serverargs" = x ] && @@
+- expr "$1" : ':[0-9][0-9]*$' > /dev/null 2>&1; then
+- display="$1"
+- else
+- serverargs="$serverargs $1"
+- fi
+- fi
+- ;;
++ /''*|\.*) if [ "$whoseargs" = "client" ]; then
++ if [ "x$clientargs" = x ]; then
++ clientargs="$1"
++ else
++ clientargs="$clientargs $1"
++ fi
++ else
++ if [ "x$serverargs" = x ]; then
++ serverargs="$1"
++ else
++ serverargs="$serverargs $1"
++ fi
++ fi ;;
++ --) whoseargs="server" ;;
++ *) if [ "$whoseargs" = "client" ]; then
++ if [ "x$clientargs" = x ]; then
++ clientargs="$defaultclientargs $1"
++ else
++ clientargs="$clientargs $1"
++ fi
++ else
++ case "$1" in
++ :[0-9]*) display="$1"; serverargs="$serverargs $1";;
++ *) serverargs="$serverargs $1" ;;
++ esac
++ fi ;;
+ esac
+ shift
+ done
+
+-XCOMM process client arguments
+-if [ x"$client" = x ]; then
+- XCOMM if no client arguments either, use rc file instead
+- if [ x"$clientargs" = x ]; then
+- client="$defaultclientargs"
+- else
+- client=$defaultclient
+- fi
++if [ x"$clientargs" = x ]; then
++ clientargs="$defaultclientargs"
+ fi
+-
+-XCOMM process server arguments
+-if [ x"$server" = x ]; then
+- XCOMM if no server arguments or display either, use rc file instead
+- if [ x"$serverargs" = x -a x"$display" = x ]; then
+- server="$defaultserverargs"
+- else
+- server=$defaultserver
+- fi
++if [ x"$serverargs" = x ]; then
++ serverargs="$defaultserverargs"
+ fi
+
+ if [ x"$XAUTHORITY" = x ]; then
+@@ -217,15 +196,8 @@
+
+ #endif
+
+-#if defined(__SCO__) || defined(__UNIXWARE__)
+-if [ "$REMOTE_SERVER" = "TRUE" ]; then
+- exec SHELL_CMD ${client}
+-else
+- XINIT $client $clientargs -- $server $display $serverargs
+-fi
+-#else
+-XINIT $client $clientargs -- $server $display $serverargs
+-#endif
++cleanup() {
++ [ -n "$PID" ] && kill $PID > /dev/null 2>&1
+
+ if [ x"$removelist" != x ]; then
+ BINDIR/xauth remove $removelist
+@@ -251,3 +223,15 @@
+ #if defined(sun)
+ kbd_mode -a
+ #endif
++}
++
++
++trap cleanup 0
++
++xinit $clientargs -- $serverargs -deferglyphs 16 &
++
++PID=$!
++
++wait $PID
++
++unset PID
+--- xinit.c.old 2005-11-11 12:30:19.199592432 -0700
++++ xinit.c 2005-11-11 12:30:47.983216656 -0700
+@@ -446,6 +446,7 @@
+ signal(SIGINT, sigCatch);
+ signal(SIGHUP, sigCatch);
+ signal(SIGPIPE, sigCatch);
++ signal(SIGTERM, sigCatch);
+ #else
+ /* Let those signal interrupt the wait() call in the main loop */
+ memset(&sa, 0, sizeof sa);
+@@ -458,6 +459,7 @@
+ sigaction(SIGINT, &sa, NULL);
+ sigaction(SIGHUP, &sa, NULL);
+ sigaction(SIGPIPE, &sa, NULL);
++ sigaction(SIGTERM, &sa, NULL);
+ #endif
+ signal(SIGALRM, sigAlarm);
+ signal(SIGUSR1, sigUsr1);
diff --git a/x11-apps/xinit/xinit-0.99.4.ebuild b/x11-apps/xinit/xinit-0.99.4.ebuild
new file mode 100644
index 000000000000..eb8db1441b34
--- /dev/null
+++ b/x11-apps/xinit/xinit-0.99.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-0.99.4.ebuild,v 1.1 2005/12/04 22:06:52 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X.Org xinit application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-wm/twm
+ x11-apps/xclock
+ x11-terms/xterm"
+DEPEND="${RDEPEND}"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization-0.99.4.patch"
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" ${S}/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe ${FILESDIR}/chooser.sh ${FILESDIR}/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/Xsession
+ exeinto /etc/X11/xinit
+ doexe ${FILESDIR}/xinitrc
+ newinitd ${FILESDIR}/xdm.start xdm
+ newpamd ${FILESDIR}/xserver.pamd xserver
+}
diff --git a/x11-apps/xkbcomp/ChangeLog b/x11-apps/xkbcomp/ChangeLog
index c7813bf3c1c8..f95ecff8ea42 100644
--- a/x11-apps/xkbcomp/ChangeLog
+++ b/x11-apps/xkbcomp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xkbcomp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbcomp/ChangeLog,v 1.12 2005/10/20 21:54:59 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbcomp/ChangeLog,v 1.13 2005/12/04 22:07:18 joshuabaergen Exp $
+
+*xkbcomp-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xkbcomp-0.99.2.ebuild:
+ Bump for 7.0RC3.
*xkbcomp-0.99.1-r1 (20 Oct 2005)
diff --git a/x11-apps/xkbcomp/files/digest-xkbcomp-0.99.2 b/x11-apps/xkbcomp/files/digest-xkbcomp-0.99.2
new file mode 100644
index 000000000000..594e675132d0
--- /dev/null
+++ b/x11-apps/xkbcomp/files/digest-xkbcomp-0.99.2
@@ -0,0 +1 @@
+MD5 9b6984a2cfb2eaf272fc39b0cdcd56e3 xkbcomp-0.99.2.tar.bz2 176458
diff --git a/x11-apps/xkbcomp/xkbcomp-0.99.2.ebuild b/x11-apps/xkbcomp/xkbcomp-0.99.2.ebuild
new file mode 100644
index 000000000000..dc5f169aa057
--- /dev/null
+++ b/x11-apps/xkbcomp/xkbcomp-0.99.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbcomp/xkbcomp-0.99.2.ebuild,v 1.1 2005/12/04 22:07:18 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib
+
+DESCRIPTION="X.Org xkbcomp application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ x-modular_src_install
+
+ dodir usr/$(get_libdir)/X11/xkb
+ dosym ../../../bin/xkbcomp /usr/$(get_libdir)/X11/xkb/xkbcomp
+}
diff --git a/x11-apps/xkbevd/ChangeLog b/x11-apps/xkbevd/ChangeLog
index 9f56d6d2401c..8fcdc0b6ff7b 100644
--- a/x11-apps/xkbevd/ChangeLog
+++ b/x11-apps/xkbevd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xkbevd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbevd/ChangeLog,v 1.5 2005/11/11 19:56:07 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbevd/ChangeLog,v 1.6 2005/12/04 22:07:43 joshuabaergen Exp $
+
+*xkbevd-0.99.3 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xkbevd-0.99.3.ebuild:
+ Bump for 7.0RC3.
*xkbevd-0.99.2 (11 Nov 2005)
diff --git a/x11-apps/xkbevd/files/digest-xkbevd-0.99.3 b/x11-apps/xkbevd/files/digest-xkbevd-0.99.3
new file mode 100644
index 000000000000..314a215cdc5e
--- /dev/null
+++ b/x11-apps/xkbevd/files/digest-xkbevd-0.99.3
@@ -0,0 +1 @@
+MD5 1053861185d47b8d87a64c1b89acacb2 xkbevd-0.99.3.tar.bz2 100954
diff --git a/x11-apps/xkbevd/xkbevd-0.99.3.ebuild b/x11-apps/xkbevd/xkbevd-0.99.3.ebuild
new file mode 100644
index 000000000000..806823682101
--- /dev/null
+++ b/x11-apps/xkbevd/xkbevd-0.99.3.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbevd/xkbevd-0.99.3.ebuild,v 1.1 2005/12/04 22:07:43 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xkbevd application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libxkbfile"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xkbprint/ChangeLog b/x11-apps/xkbprint/ChangeLog
index 3c68a607de70..e5fe17fe4086 100644
--- a/x11-apps/xkbprint/ChangeLog
+++ b/x11-apps/xkbprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xkbprint
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbprint/ChangeLog,v 1.5 2005/11/17 13:32:27 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbprint/ChangeLog,v 1.6 2005/12/04 22:08:12 joshuabaergen Exp $
+
+*xkbprint-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xkbprint-0.99.2.ebuild:
+ Bump for 7.0RC3.
17 Nov 2005; Herbie Hopkins <herbs@gentoo.org> xkbprint-0.99.1.ebuild:
Marked ~amd64.
diff --git a/x11-apps/xkbprint/files/digest-xkbprint-0.99.2 b/x11-apps/xkbprint/files/digest-xkbprint-0.99.2
new file mode 100644
index 000000000000..d2e9ce8743b7
--- /dev/null
+++ b/x11-apps/xkbprint/files/digest-xkbprint-0.99.2
@@ -0,0 +1 @@
+MD5 ff363cd429fd03bb3a686a3159daceec xkbprint-0.99.2.tar.bz2 113971
diff --git a/x11-apps/xkbprint/xkbprint-0.99.2.ebuild b/x11-apps/xkbprint/xkbprint-0.99.2.ebuild
new file mode 100644
index 000000000000..80d2a3326c28
--- /dev/null
+++ b/x11-apps/xkbprint/xkbprint-0.99.2.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbprint/xkbprint-0.99.2.ebuild,v 1.1 2005/12/04 22:08:12 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xkbprint application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libxkbfile"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xkbutils/ChangeLog b/x11-apps/xkbutils/ChangeLog
index a1a80f0d8a6c..8b49633e2f9a 100644
--- a/x11-apps/xkbutils/ChangeLog
+++ b/x11-apps/xkbutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xkbutils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbutils/ChangeLog,v 1.5 2005/11/17 13:35:34 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbutils/ChangeLog,v 1.6 2005/12/04 22:08:37 joshuabaergen Exp $
+
+*xkbutils-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xkbutils-0.99.2.ebuild:
+ Bump for 7.0RC3.
17 Nov 2005; Herbie Hopkins <herbs@gentoo.org> xkbutils-0.99.1.ebuild:
Marked ~amd64.
diff --git a/x11-apps/xkbutils/files/digest-xkbutils-0.99.2 b/x11-apps/xkbutils/files/digest-xkbutils-0.99.2
new file mode 100644
index 000000000000..b74cd0dca752
--- /dev/null
+++ b/x11-apps/xkbutils/files/digest-xkbutils-0.99.2
@@ -0,0 +1 @@
+MD5 24177761ac1fd1ac1443f0f6c328af39 xkbutils-0.99.2.tar.bz2 64614
diff --git a/x11-apps/xkbutils/xkbutils-0.99.2.ebuild b/x11-apps/xkbutils/xkbutils-0.99.2.ebuild
new file mode 100644
index 000000000000..ead162fff86c
--- /dev/null
+++ b/x11-apps/xkbutils/xkbutils-0.99.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbutils/xkbutils-0.99.2.ebuild,v 1.1 2005/12/04 22:08:37 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xkbutils application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libxkbfile
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
diff --git a/x11-apps/xkill/ChangeLog b/x11-apps/xkill/ChangeLog
index a5dc7418d605..3ecda63f8b45 100644
--- a/x11-apps/xkill/ChangeLog
+++ b/x11-apps/xkill/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xkill
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkill/ChangeLog,v 1.5 2005/11/17 13:30:54 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkill/ChangeLog,v 1.6 2005/12/04 22:09:08 joshuabaergen Exp $
+
+*xkill-0.99.2 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xkill-0.99.2.ebuild:
+ Bump for 7.0RC3.
17 Nov 2005; Herbie Hopkins <herbs@gentoo.org> xkill-0.99.1.ebuild:
Marked ~amd64.
diff --git a/x11-apps/xkill/files/digest-xkill-0.99.2 b/x11-apps/xkill/files/digest-xkill-0.99.2
new file mode 100644
index 000000000000..25909188c2cc
--- /dev/null
+++ b/x11-apps/xkill/files/digest-xkill-0.99.2
@@ -0,0 +1 @@
+MD5 bfe44de60770d1ad4f4568b75d8934b8 xkill-0.99.2.tar.bz2 75965
diff --git a/x11-apps/xkill/xkill-0.99.2.ebuild b/x11-apps/xkill/xkill-0.99.2.ebuild
new file mode 100644
index 000000000000..b48663e335cf
--- /dev/null
+++ b/x11-apps/xkill/xkill-0.99.2.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkill/xkill-0.99.2.ebuild,v 1.1 2005/12/04 22:09:08 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xkill application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"