summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-simulation/simutrans/ChangeLog7
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch96
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch11
-rw-r--r--games-simulation/simutrans/simutrans-0.112.3.ebuild62
4 files changed, 6 insertions, 170 deletions
diff --git a/games-simulation/simutrans/ChangeLog b/games-simulation/simutrans/ChangeLog
index d0a90eed7ebc..8cf07d36f9ed 100644
--- a/games-simulation/simutrans/ChangeLog
+++ b/games-simulation/simutrans/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/simutrans
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.40 2015/05/27 11:15:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.41 2015/06/26 18:02:12 mr_bones_ Exp $
+
+ 26 Jun 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/simutrans-0.112.3-Makefile.patch,
+ -files/simutrans-0.112.3-overflow.patch, -simutrans-0.112.3.ebuild:
+ old
27 May 2015; Agostino Sarubbo <ago@gentoo.org> simutrans-0.120.0.1.ebuild:
Stable for x86, wrt bug #549386
diff --git a/games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch b/games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch
deleted file mode 100644
index a27316438002..000000000000
--- a/games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch
+++ /dev/null
@@ -1,96 +0,0 @@
---- Makefile.orig
-+++ Makefile
-@@ -88,8 +88,6 @@
- endif
- endif
- endif
--else
-- CFLAGS += -O
- endif
-
- ifdef DEBUG
-@@ -108,6 +106,7 @@
- endif
- else
- CFLAGS += -DNDEBUG
-+ CXXFLAGS += -DNDEBUG
- endif
-
- ifneq ($(PROFILE),)
-@@ -120,6 +119,7 @@
-
- ifneq ($(MULTI_THREAD),)
- CFLAGS += -DMULTI_THREAD=$(MULTI_THREAD)
-+ CXXFLAGS += -DMULTI_THREAD=$(MULTI_THREAD)
- ifneq ($(MULTI_THREAD),1)
- ifeq ($(OSTYPE),mingw)
- #use lpthreadGC2d for debug alternatively
-@@ -134,10 +134,12 @@
- REV = $(shell svnversion)
- ifneq ($(REV),)
- CFLAGS += -DREVISION="$(REV)"
-+ CXXFLAGS += -DREVISION="$(REV)"
- endif
- endif
-
- CFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
-+CXXFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
- CCFLAGS += -Wstrict-prototypes
-
-
-@@ -456,6 +458,7 @@
- ifeq ($(BACKEND),sdl)
- SOURCES += simsys_s.cc
- CFLAGS += -DUSE_16BIT_DIB
-+ CXXFLAGS += -DUSE_16BIT_DIB
- ifeq ($(OSTYPE),mac)
- # Core Audio (Quicktime) base sound system routines
- SOURCES += sound/core-audio_sound.mm
-@@ -488,6 +491,7 @@
- endif
- endif
- CFLAGS += $(SDL_CFLAGS)
-+ CXXFLAGS += $(SDL_CFLAGS)
- LIBS += $(SDL_LDFLAGS)
- endif
-
-@@ -497,6 +501,7 @@
- SOURCES += sound/sdl_mixer_sound.cc
- SOURCES += music/sdl_midi.cc
- CFLAGS += -DUSE_16BIT_DIB
-+ CXXFLAGS += -DUSE_16BIT_DIB
- ifeq ($(SDL_CONFIG),)
- SDL_CFLAGS := -I$(MINGDIR)/include/SDL -Dmain=SDL_main
- SDL_LDFLAGS := -lmingw32 -lSDLmain -lSDL
-@@ -511,6 +516,7 @@
- endif
- endif
- CFLAGS += $(SDL_CFLAGS)
-+ CXXFLAGS += $(SDL_CFLAGS)
- LIBS += $(SDL_LDFLAGS) -lSDL_mixer
- endif
-
-@@ -544,6 +550,7 @@
- endif
- endif
- CFLAGS += $(SDL_CFLAGS)
-+ CXXFLAGS += $(SDL_CFLAGS)
- LIBS += $(SDL_LDFLAGS) -lglew32
- ifeq ($(OSTYPE),mingw)
- LIBS += -lopengl32
-@@ -559,6 +566,7 @@
- endif
-
- CFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
-+CXXFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
-
- ifneq ($(findstring $(OSTYPE), cygwin mingw),)
- SOURCES += simres.rc
-@@ -566,7 +574,6 @@
- endif
-
- CCFLAGS += $(CFLAGS)
--CXXFLAGS += $(CFLAGS)
-
- BUILDDIR ?= build/$(CFG)
- PROGDIR ?= $(BUILDDIR)
diff --git a/games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch b/games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch
deleted file mode 100644
index b50f3b888422..000000000000
--- a/games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- besch/reader/obj_reader.cc.orig
-+++ besch/reader/obj_reader.cc
-@@ -308,7 +308,7 @@
- void obj_reader_t::skip_nodes(FILE *fp,uint32 version)
- {
- obj_node_info_t node;
-- char load_dummy[OBJ_NODE_INFO_SIZE], *p;
-+ char load_dummy[OBJ_NODE_INFO_SIZE + 4], *p; // extra 4 for LARGE_RECORD_SIZE
-
- p = load_dummy;
- if( version==COMPILER_VERSION_CODE_11 ) {
diff --git a/games-simulation/simutrans/simutrans-0.112.3.ebuild b/games-simulation/simutrans/simutrans-0.112.3.ebuild
deleted file mode 100644
index fdcefd508632..000000000000
--- a/games-simulation/simutrans/simutrans-0.112.3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/simutrans-0.112.3.ebuild,v 1.4 2014/10/12 08:52:39 ago Exp $
-
-EAPI=5
-inherit flag-o-matic eutils games
-
-MY_PV=${PV/0./}
-MY_PV=${MY_PV//./-}
-DESCRIPTION="A free Transport Tycoon clone"
-HOMEPAGE="http://www.simutrans.com/"
-SRC_URI="mirror://sourceforge/simutrans/simutrans-src-${MY_PV}.zip
- mirror://sourceforge/simutrans/simulinux-${MY_PV}.zip
- mirror://sourceforge/simutrans/simupak64-${MY_PV}.zip"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[sound,video]
- sys-libs/zlib
- app-arch/bzip2
- media-libs/libpng:0
- media-libs/sdl-mixer"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-src_prepare() {
- strip-flags # bug #293927
- echo "BACKEND=mixer_sdl
-COLOUR_DEPTH=16
-OSTYPE=linux
-VERBOSE=1" > config.default || die
-
- if use !x86 ; then
- echo "FLAGS+= -DUSE_C" >> config.default || die
- fi
- # make it look in the install location for the data
- sed -i \
- -e "s:argv\[0\]:\"${GAMES_DATADIR}/${PN}/\":" \
- simmain.cc || die
-
- epatch \
- "${FILESDIR}"/${P}-Makefile.patch \
- "${FILESDIR}"/${P}-overflow.patch
- rm -f simutrans/{simutrans,*.txt}
- mv simutrans/get_pak.sh "${T}" || die
-}
-
-src_install() {
- newgamesbin build/default/sim ${PN}
- dogamesbin "${T}"/get_pak.sh
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r simutrans/*
- dodoc documentation/*
- doicon simutrans.ico
- make_desktop_entry simutrans Simutrans /usr/share/pixmaps/simutrans.ico
- prepgamesdirs
-}