summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/torque/ChangeLog6
-rw-r--r--sys-cluster/torque/torque-1.2.0_p1-r3.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index ebbc806290fe..4e03a262bec8 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/torque
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.17 2005/07/21 03:38:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.18 2005/08/11 18:09:57 robbat2 Exp $
+
+ 11 Aug 2005; Robin H. Johnson <robbat2@gentoo.org>
+ torque-1.2.0_p1-r3.ebuild:
+ Preserve server_name where possible.
21 Jul 2005; Robin H. Johnson <robbat2@gentoo.org>
torque-1.2.0_p1-r3.ebuild:
diff --git a/sys-cluster/torque/torque-1.2.0_p1-r3.ebuild b/sys-cluster/torque/torque-1.2.0_p1-r3.ebuild
index e583d91831f3..0995ed70b59d 100644
--- a/sys-cluster/torque/torque-1.2.0_p1-r3.ebuild
+++ b/sys-cluster/torque/torque-1.2.0_p1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p1-r3.ebuild,v 1.2 2005/07/21 03:38:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p1-r3.ebuild,v 1.3 2005/08/11 18:09:57 robbat2 Exp $
inherit flag-o-matic eutils
@@ -117,6 +117,10 @@ src_install() {
else
touch ${D}/etc/pbs_environment
fi
+
+ if [ -f "${ROOT}/usr/spool/PBS/server_name" ]; then
+ cp "${ROOT}/usr/spool/PBS/server_name" "${D}/usr/spool/PBS/server_name"
+ fi
}
pkg_postinst() {