summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/rsbac-sources/ChangeLog7
-rw-r--r--sys-kernel/rsbac-sources/rsbac-sources-3.2.19.ebuild35
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/rsbac-sources/ChangeLog b/sys-kernel/rsbac-sources/ChangeLog
index 480ed3bb9901..f54dc74bdba4 100644
--- a/sys-kernel/rsbac-sources/ChangeLog
+++ b/sys-kernel/rsbac-sources/ChangeLog
@@ -1,5 +1,12 @@
+*rsbac-sources-3.2.19 (09 Jun 2012)
+
+ 09 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
+ +rsbac-sources-3.2.19.ebuild:
+ Based on 3.2.19 + 4500_patch-linux-3.2.19-rsbac-1.4.6.diff
+ 4520_pax-linux-3.2.18-test49.patch included for testing but not applied
+
*rsbac-sources-3.1.5 (07 Jan 2012)
07 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
diff --git a/sys-kernel/rsbac-sources/rsbac-sources-3.2.19.ebuild b/sys-kernel/rsbac-sources/rsbac-sources-3.2.19.ebuild
new file mode 100644
index 000000000000..aa4242310bcd
--- /dev/null
+++ b/sys-kernel/rsbac-sources/rsbac-sources-3.2.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rsbac-sources/rsbac-sources-3.2.19.ebuild,v 1.1 2012/06/09 12:09:10 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="15"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/rsbac-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/rsbac-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch 4520_pax-linux-3.2.18-test49.patch"
+
+DESCRIPTION="Hardened + RSBAC kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ ewarn
+ ewarn "Note: the pax patches have not been applied however they are included"
+ ewarn "in the patchset. If you want to try to apply them, edit UNIPATCH_EXCLUDE"
+ ewarn "in this ebuild. Expect breakage ;)"
+ ewarn
+}