summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-21 00:16:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-21 00:16:37 +0000
commit24cd048773fe19906109e360ca665b5afab98ab4 (patch)
tree9ed360d1b97ec1780523d924692f9fcd08dee751 /xfce-extra/xfswitch-plugin
parentAdd patch for building with gcc-4.7, fixes bug #409161. Bump EAPI. (diff)
downloadgentoo-2-24cd048773fe19906109e360ca665b5afab98ab4.tar.gz
gentoo-2-24cd048773fe19906109e360ca665b5afab98ab4.tar.bz2
gentoo-2-24cd048773fe19906109e360ca665b5afab98ab4.zip
lightdm support
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfswitch-plugin')
-rw-r--r--xfce-extra/xfswitch-plugin/ChangeLog14
-rw-r--r--xfce-extra/xfswitch-plugin/metadata.xml3
-rw-r--r--xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r1.ebuild45
3 files changed, 58 insertions, 4 deletions
diff --git a/xfce-extra/xfswitch-plugin/ChangeLog b/xfce-extra/xfswitch-plugin/ChangeLog
index a83bf86e2720..0259b1034060 100644
--- a/xfce-extra/xfswitch-plugin/ChangeLog
+++ b/xfce-extra/xfswitch-plugin/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for xfce-extra/xfswitch-plugin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfswitch-plugin/ChangeLog,v 1.5 2011/09/29 14:29:31 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfswitch-plugin/ChangeLog,v 1.6 2012/04/21 00:16:37 ssuominen Exp $
+
+*xfswitch-plugin-0.0.1-r1 (21 Apr 2012)
+
+ 21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfswitch-plugin-0.0.1-r1.ebuild, metadata.xml:
+ Use gdmflexiserver from x11-misc/lightdm by default (and introduce USE="gdm"
+ to use it from gnome-base/gdm instead) wrt #411921 by "Rion"
29 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
xfswitch-plugin-0.0.1.ebuild:
- Remove USE="debug" (pointless to debug plugins still using libxfcegui4) wrt
- #381093
+ Temporarily remove USE="debug" while waiting for libxfce4ui port wrt #381093
19 May 2011; Samuli Suominen <ssuominen@gentoo.org>
xfswitch-plugin-0.0.1.ebuild:
diff --git a/xfce-extra/xfswitch-plugin/metadata.xml b/xfce-extra/xfswitch-plugin/metadata.xml
index d56729e92f8e..a16265a9d686 100644
--- a/xfce-extra/xfswitch-plugin/metadata.xml
+++ b/xfce-extra/xfswitch-plugin/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>xfce</herd>
+ <use>
+ <flag name='gdm'>Use gdmflexiserver from <pkg>gnome-base/gdm</pkg> instead of <pkg>x11-misc/lightdm</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r1.ebuild b/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..f16106d1e4ca
--- /dev/null
+++ b/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r1.ebuild,v 1.1 2012/04/21 00:16:37 ssuominen Exp $
+
+EAPI=4
+inherit multilib xfconf
+
+DESCRIPTION="A panel plug-in for user switching (using x11-misc/lightdm or gnome-base/gdm)"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfswitch-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gdm"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
+RDEPEND="${COMMON_DEPEND}
+ gdm? ( gnome-base/gdm )
+ !gdm? ( x11-misc/lightdm )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+src_prepare() {
+ if ! use gdm; then
+ sed -i \
+ -e '/command/s:gdmflexiserver:/usr/libexec/lightdm/&:' \
+ panel-plugin/main.c || die
+ fi
+
+ xfconf_src_prepare
+}