summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-17 07:15:03 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-17 07:15:03 +0000
commit9c62d293a4ac6425e8e791075dcf86e9d34900f1 (patch)
tree17e24e80e12926c737a9ef10d817c59c7b475479 /xfce-extra/xfce4-smartbookmark-plugin
parentVersion bump. (diff)
downloadgentoo-2-9c62d293a4ac6425e8e791075dcf86e9d34900f1.tar.gz
gentoo-2-9c62d293a4ac6425e8e791075dcf86e9d34900f1.tar.bz2
gentoo-2-9c62d293a4ac6425e8e791075dcf86e9d34900f1.zip
Fix argument handling too for last change (move to exo-open)
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/ChangeLog9
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/files/xfce4-smartbookmark-plugin-0.4.4-exo-open_and_argument_handling.patch39
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r2.ebuild43
3 files changed, 90 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
index a68a0f1533b0..f206d895223c 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
+++ b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-smartbookmark-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.9 2012/04/02 11:53:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.10 2012/04/17 07:15:03 ssuominen Exp $
+
+*xfce4-smartbookmark-plugin-0.4.4-r2 (17 Apr 2012)
+
+ 17 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-smartbookmark-plugin-0.4.4-r2.ebuild,
+ +files/xfce4-smartbookmark-plugin-0.4.4-exo-open_and_argument_handling.patch:
+ Fix argument handling too for last change (move to exo-open)
*xfce4-smartbookmark-plugin-0.4.4-r1 (02 Apr 2012)
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/files/xfce4-smartbookmark-plugin-0.4.4-exo-open_and_argument_handling.patch b/xfce-extra/xfce4-smartbookmark-plugin/files/xfce4-smartbookmark-plugin-0.4.4-exo-open_and_argument_handling.patch
new file mode 100644
index 000000000000..43cc4565f837
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/files/xfce4-smartbookmark-plugin-0.4.4-exo-open_and_argument_handling.patch
@@ -0,0 +1,39 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=8642
+
+--- src/smartbookmark.c
++++ src/smartbookmark.c
+@@ -75,18 +75,27 @@ XFCE_PANEL_PLUGIN_REGISTER_INTERNAL(smar
+
+ static gboolean do_search(const char *url, const char *keyword)
+ {
++ gchar *argv[] = { "exo-open", "--launch", "WebBrowser", NULL, NULL };
++ gchar *complete_url;
++ gboolean retval;
++ GError *error = NULL;
++
+ DBG ("Do search");
+- gchar *execute;
+- gboolean success;
+- execute = g_strconcat("xfbrowser4 \"", url, NULL);//works better for me
+- //execute = g_strconcat("x-www-browser \"", url, NULL);
+- execute = g_strconcat(execute, keyword, NULL);
+- execute = g_strconcat(execute, "\"", NULL);
+
+- success = exec_command(execute);
+- g_free(execute);
++ complete_url = g_strconcat(url, keyword, NULL);
++ argv[3] = complete_url;
++
++ retval = g_spawn_async(NULL, (gchar **)argv, NULL,
++ G_SPAWN_SEARCH_PATH | G_SPAWN_DO_NOT_REAP_CHILD, NULL, NULL, NULL, &error);
++
++ g_free(complete_url);
++
++ if (!retval) {
++ xfce_err("%s", error->message);
++ g_error_free(error);
++ }
+
+- return success;
++ return retval;
+ }
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r2.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r2.ebuild
new file mode 100644
index 000000000000..a8a33518b132
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r2.ebuild,v 1.1 2012/04/17 07:15:03 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/exo-0.6"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-exo-open_and_argument_handling.patch
+ )
+
+ XFCONF=(
+ --disable-static
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+src_prepare() {
+ sed -i -e 's:bugs.debian:bugs.gentoo:' src/smartbookmark.c || die
+ xfconf_src_prepare
+}