summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-22 00:40:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-22 00:40:57 +0000
commit3a9dc1863fc71048807c04af5c5c6e27b5093fe9 (patch)
treefe0192ef846572a5d558ff17f1d54d1e78549677 /xfce-extra/xfce4-smartbookmark-plugin
parentRemove old flags from metadata (diff)
downloadgentoo-2-3a9dc1863fc71048807c04af5c5c6e27b5093fe9.tar.gz
gentoo-2-3a9dc1863fc71048807c04af5c5c6e27b5093fe9.tar.bz2
gentoo-2-3a9dc1863fc71048807c04af5c5c6e27b5093fe9.zip
Version bump.
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.5.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
index 3023112c4252..fa3b9524e0fc 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
+++ b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-smartbookmark-plugin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.19 2012/11/28 12:19:21 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.20 2013/01/22 00:40:57 ssuominen Exp $
+
+*xfce4-smartbookmark-plugin-0.4.5 (22 Jan 2013)
+
+ 22 Jan 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-smartbookmark-plugin-0.4.5.ebuild:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-smartbookmark-plugin-0.4.4-r2.ebuild:
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.5.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.5.ebuild
new file mode 100644
index 000000000000..b20b5054f15c
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.5.ebuild,v 1.1 2013/01/22 00:40:57 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfce4-panel-4.10"
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/exo-0.8"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+src_prepare() {
+ sed -i -e '/bugs/s:debian:gentoo:' src/smartbookmark.c || die
+ xfconf_src_prepare
+}