summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-07-15 03:10:27 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-07-15 03:10:27 +0000
commit8223ee3a5eec0e2a8fddd271afa8e3aaabdc617f (patch)
tree0f3bcc43b02a0f9118a9dd2f0eb0bc8c361a87d5 /xfce-base
parentNew version and portage directory layout. (diff)
downloadgentoo-2-8223ee3a5eec0e2a8fddd271afa8e3aaabdc617f.tar.gz
gentoo-2-8223ee3a5eec0e2a8fddd271afa8e3aaabdc617f.tar.bz2
gentoo-2-8223ee3a5eec0e2a8fddd271afa8e3aaabdc617f.zip
New version and portage directory layout.
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce-utils/ChangeLog14
-rw-r--r--xfce-base/xfce-utils/Manifest4
-rw-r--r--xfce-base/xfce-utils/files/digest-xfce-utils-3.99.11
-rw-r--r--xfce-base/xfce-utils/xfce-utils-3.99.1.ebuild40
-rw-r--r--xfce-base/xfdesktop/ChangeLog14
-rw-r--r--xfce-base/xfdesktop/Manifest4
-rw-r--r--xfce-base/xfdesktop/files/digest-xfdesktop-3.99.11
-rw-r--r--xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild38
8 files changed, 112 insertions, 4 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
new file mode 100644
index 000000000000..441b7b750ce7
--- /dev/null
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for x11-misc/xfce-utils
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.1 2003/07/15 03:07:16 bcowan Exp $
+
+*xfce-utils-3.99.1 (14 Jul 2003)
+
+ 14 Jul 2003; Brad Cowan <bcowan@gentoo.org> xfce-utils-3.99.1.ebuild:
+ New version and portage directory structure.
+
+*xfce-utils-3.90.0 (13 Jun 2003)
+
+ 13 Jun 2003; Brad Cowan <bcowan@gentoo.org> xfce-utils-3.90.0.ebuild:
+ Initial import.
+
diff --git a/xfce-base/xfce-utils/Manifest b/xfce-base/xfce-utils/Manifest
index cd5b41be90a9..b04fb27f4dbf 100644
--- a/xfce-base/xfce-utils/Manifest
+++ b/xfce-base/xfce-utils/Manifest
@@ -1,3 +1,3 @@
-MD5 315fe321348273b21972749275cdc6c7 ChangeLog 345
-MD5 c892e073d917b452256e177dd5b41025 xfce-utils-3.99.1.ebuild 1065
+MD5 2d452057f3d0f81014f37b09751e567a ChangeLog 500
+MD5 f4cd534a4f8f10fdb8a72ac9914b48cc xfce-utils-3.99.1.ebuild 1173
MD5 ef4218ddac196b3864971df7d549f868 files/digest-xfce-utils-3.99.1 69
diff --git a/xfce-base/xfce-utils/files/digest-xfce-utils-3.99.1 b/xfce-base/xfce-utils/files/digest-xfce-utils-3.99.1
new file mode 100644
index 000000000000..4748e0f0b464
--- /dev/null
+++ b/xfce-base/xfce-utils/files/digest-xfce-utils-3.99.1
@@ -0,0 +1 @@
+MD5 04d9e7bfbfbec4f1608549b7abacdb32 xfce-utils-3.99.1.tar.gz 702580
diff --git a/xfce-base/xfce-utils/xfce-utils-3.99.1.ebuild b/xfce-base/xfce-utils/xfce-utils-3.99.1.ebuild
new file mode 100644
index 000000000000..76c291e9d4c9
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-3.99.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-3.99.1.ebuild,v 1.1 2003/07/15 03:07:16 bcowan Exp $
+
+IUSE="X gtkhtml gnome"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Xfce4 utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce4-rc1/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+ use gtkhtml && myconf="${myconf} --enable-gtkhtml"
+ use gnome && myconf="${myconf} --enable-gdm"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL NEWS COPYING README ChangeLog TODO
+}
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
new file mode 100644
index 000000000000..6bbba1a5143a
--- /dev/null
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for x11-misc/xfdesktop
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.1 2003/07/15 03:10:09 bcowan Exp $
+
+*xfdesktop-3.99.1 (14 Jul 2003)
+
+ 14 Jul 2003; Brad Cowan <bcowan@gentoo.org> xfdesktop-3.99.1.ebuild:
+ New version and portage directory structure.
+
+*xfdesktop-3.90.0 (13 Jun 2003)
+
+ 13 Jun 2003; Brad Cowan <bcowan@gentoo.org> xfdesktop-3.90.0.ebuild:
+ Initial import.
+
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 3c1127fdeb41..792f00c5bd95 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,3 +1,3 @@
-MD5 804dc8d5bd6870029e41f62dbaf65f5e xfdesktop-3.99.1.ebuild 949
-MD5 41598269b83ca8fe3c4e79e2358276ad ChangeLog 341
+MD5 6be16c1645022d87797d5c143d1345a7 xfdesktop-3.99.1.ebuild 1055
+MD5 087a31480af5bb3f9725d46b722696c0 ChangeLog 494
MD5 928e09351eaa8730aa1f88081c262e10 files/digest-xfdesktop-3.99.1 69
diff --git a/xfce-base/xfdesktop/files/digest-xfdesktop-3.99.1 b/xfce-base/xfdesktop/files/digest-xfdesktop-3.99.1
new file mode 100644
index 000000000000..ccc5e0192a74
--- /dev/null
+++ b/xfce-base/xfdesktop/files/digest-xfdesktop-3.99.1
@@ -0,0 +1 @@
+MD5 f7bad244ace48eaa519e9a444a5c922a xfdesktop-3.99.1.tar.gz 1839648
diff --git a/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild b/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild
new file mode 100644
index 000000000000..6e2119bf1a1f
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild,v 1.1 2003/07/15 03:10:09 bcowan Exp $
+
+IUSE="X"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Xfce4 desktop"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce4-rc1/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL NEWS COPYING README ChangeLog TODO
+}