summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-09-23 16:51:42 +0000
committerChristoph Mende <angelos@gentoo.org>2011-09-23 16:51:42 +0000
commitba3b8acc88f59a3988a077042b3f3f440f284cf9 (patch)
tree3d5f514d9a7a249ab3a90aba99b0bbaf0d63e741 /xfce-base/xfwm4
parentVersion bump (diff)
downloadgentoo-2-ba3b8acc88f59a3988a077042b3f3f440f284cf9.tar.gz
gentoo-2-ba3b8acc88f59a3988a077042b3f3f440f284cf9.tar.bz2
gentoo-2-ba3b8acc88f59a3988a077042b3f3f440f284cf9.zip
Version bump
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfwm4')
-rw-r--r--xfce-base/xfwm4/ChangeLog7
-rw-r--r--xfce-base/xfwm4/xfwm4-4.8.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/xfce-base/xfwm4/ChangeLog b/xfce-base/xfwm4/ChangeLog
index 9974bc829985..babdc811f9a6 100644
--- a/xfce-base/xfwm4/ChangeLog
+++ b/xfce-base/xfwm4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfwm4
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.172 2011/07/05 06:25:19 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.173 2011/09/23 16:51:42 angelos Exp $
+
+*xfwm4-4.8.2 (23 Sep 2011)
+
+ 23 Sep 2011; Christoph Mende <angelos@gentoo.org> +xfwm4-4.8.2.ebuild:
+ Version bump
05 Jul 2011; Christoph Mende <angelos@gentoo.org> xfwm4-4.8.1.ebuild:
Remove libXpm dependency
diff --git a/xfce-base/xfwm4/xfwm4-4.8.2.ebuild b/xfce-base/xfwm4/xfwm4-4.8.2.ebuild
new file mode 100644
index 000000000000..e878debc7ada
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.8.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.8.2.ebuild,v 1.1 2011/09/23 16:51:42 angelos Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfwm4/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug startup-notification +xcomposite"
+
+RDEPEND=">=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.14:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/pango
+ >=x11-libs/libwnck-2.22:1
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfconf-4.8
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xcomposite compositor)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+}