summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-24 15:41:20 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-24 15:41:20 +0000
commitfb5a17f772b8428a2922fa10caa98094594526db (patch)
tree9f7a01453ec0335db26cb23ba98c62942bd2c931 /x11-wm
parentFixed manifest. (diff)
downloadgentoo-2-fb5a17f772b8428a2922fa10caa98094594526db.tar.gz
gentoo-2-fb5a17f772b8428a2922fa10caa98094594526db.tar.bz2
gentoo-2-fb5a17f772b8428a2922fa10caa98094594526db.zip
Revbump to add IUSE=opengl (bug 470274, thanks Oliver Freyermuth). Make opengl default to auto and improve --help output. Replace configuration patches with setup.py --with/--without syntax. IUSE=sound adopted from upstream, but untested.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xpra/ChangeLog11
-rw-r--r--x11-wm/xpra/files/xpra-0.9.5-opengl-auto.patch50
-rw-r--r--x11-wm/xpra/xpra-0.9.5-r2.ebuild101
3 files changed, 161 insertions, 1 deletions
diff --git a/x11-wm/xpra/ChangeLog b/x11-wm/xpra/ChangeLog
index d71d5f53aca2..379594ead7ab 100644
--- a/x11-wm/xpra/ChangeLog
+++ b/x11-wm/xpra/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-wm/xpra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/ChangeLog,v 1.70 2013/06/17 08:03:09 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/ChangeLog,v 1.71 2013/06/24 15:41:19 xmw Exp $
+
+*xpra-0.9.5-r2 (24 Jun 2013)
+
+ 24 Jun 2013; Michael Weber <xmw@gentoo.org>
+ +files/xpra-0.9.5-opengl-auto.patch, +xpra-0.9.5-r2.ebuild:
+ Revbump to add IUSE=opengl (bug 470274, thanks Oliver Freyermuth). Make opengl
+ default to auto and improve --help output. Replace configuration patches with
+ setup.py --with/--without syntax. IUSE=sound adopted from upstream, but
+ untested.
17 Jun 2013; Michael Weber <xmw@gentoo.org> -xpra-0.9.4-r1.ebuild,
-xpra-0.9.4.ebuild, -xpra-0.9.5.ebuild:
diff --git a/x11-wm/xpra/files/xpra-0.9.5-opengl-auto.patch b/x11-wm/xpra/files/xpra-0.9.5-opengl-auto.patch
new file mode 100644
index 000000000000..29a3ca067a5e
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.9.5-opengl-auto.patch
@@ -0,0 +1,50 @@
+--- xpra-0.9.5/xpra/scripts/config.py
++++ xpra-0.9.5/xpra/scripts/config.py
+@@ -117,9 +117,10 @@
+ if e.args[0]==errno.EACCES:
+ return "VirtualBox is present (VBoxMiniRdrDN)"
+ return None
+-OPENGL_DEFAULT = False
+-#if OpenGL_safety_check() is not None:
+-# OPENGL_DEFAULT = False
++if OpenGL_safety_check() is not None:
++ OPENGL_DEFAULT = False
++else:
++ OPENGL_DEFAULT = None
+
+
+
+@@ -452,6 +453,13 @@
+ else:
+ warn("Warning: cannot parse value '%s' for '%s' as a boolean" % (v, k))
+
++def print_bool(k, v):
++ if type(v)==type(None):
++ return 'auto'
++ if type(v)==bool:
++ return v and 'yes' or 'no'
++ warn("Warning: cannot print value '%s' for '%s' as a boolean" % (v, k))
++
+ def parse_number(numtype, k, v, auto=-1):
+ if type(v)==str:
+ v = v.lower()
+--- xpra-0.9.5/xpra/scripts/main.py
++++ xpra-0.9.5/xpra/scripts/main.py
+@@ -24,7 +24,7 @@
+ get_default_socket_dir,
+ init as platform_init)
+ from xpra.bytestreams import TwoFileConnection, SocketConnection
+-from xpra.scripts.config import ENCODINGS, ENCRYPTION_CIPHERS, make_defaults_struct, show_codec_help, parse_bool
++from xpra.scripts.config import ENCODINGS, ENCRYPTION_CIPHERS, make_defaults_struct, show_codec_help, parse_bool, print_bool
+ from wimpiggy.gobject_compat import import_gobject
+
+ SIGNAMES = {signal.SIGINT:"SIGINT", signal.SIGTERM:"SIGTERM"}
+@@ -253,7 +253,7 @@
+ "These options control client features that affect the appearance or the keyboard.")
+ parser.add_option_group(group)
+ group.add_option("--opengl", action="store",
+- dest="opengl", default=defaults.opengl,
++ dest="opengl", default=print_bool('opengl', defaults.opengl),
+ help="Use OpenGL accelerated rendering, options: yes,no,auto. Default: %default.")
+ group.add_option("--no-windows", action="store_false",
+ dest="windows", default=defaults.windows,
diff --git a/x11-wm/xpra/xpra-0.9.5-r2.ebuild b/x11-wm/xpra/xpra-0.9.5-r2.ebuild
new file mode 100644
index 000000000000..174d19799943
--- /dev/null
+++ b/x11-wm/xpra/xpra-0.9.5-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/xpra-0.9.5-r2.ebuild,v 1.1 2013/06/24 15:41:19 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit distutils-r1 eutils
+
+DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
+HOMEPAGE="http://xpra.org/"
+SRC_URI="http://xpra.org/src/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+clipboard opengl pulseaudio +rencode server sound vpx webp x264"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# x264/old-libav.path situation see bug 459218
+COMMON_DEPEND=""${PYTHON_DEPS}"
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ opengl? ( dev-python/pygtkglext )
+ pulseaudio? ( media-sound/pulseaudio )
+ sound? ( media-libs/gstreamer
+ media-libs/gst-plugins-base
+ dev-python/gst-python )
+ vpx? ( media-libs/libvpx
+ virtual/ffmpeg )
+ webp? ( media-libs/libwebp )
+ x264? ( media-libs/x264
+ || ( >=media-video/ffmpeg-1.0.4 media-video/libav )
+ virtual/ffmpeg )"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ virtual/ssh
+ x11-apps/setxkbmap
+ x11-apps/xmodmap
+ server? ( x11-base/xorg-server[-minimal,xvfb]
+ x11-drivers/xf86-input-void
+ x11-drivers/xf86-video-dummy
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.7.1-ignore-gentoo-no-compile.patch \
+ "${FILESDIR}"/${PN}-0.8.0-prefix.patch \
+ "${FILESDIR}"/${PN}-0.9.5-PIL.patch \
+ "${FILESDIR}"/${PN}-0.9.5-opengl-auto.patch
+
+ #assuming ffmpeg and libav mutual exclusive installs
+ if has_version "media-video/libav" ; then
+ if ! has_version ">=media-video/libav-9" ; then
+ epatch patches/old-libav.patch
+ fi
+ fi
+}
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(use_with clipboard)
+ $(use_with opengl)
+ $(use_with rencode)
+ $(use_with server)
+ $(use_with sound)
+ $(use_with vpx)
+ $(use_with webp)
+ $(use_with x264)
+ --with-cymaths
+ --with-cyxor
+ --with-parti
+ --with-shadow
+ --with-strict
+ --with-warn
+ --without-PIC
+ --without-debug )
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -vf "${ED}"usr/share/parti/{parti.,}README \
+ "${ED}"usr/share/xpra/{webm/LICENSE,xpra.README} \
+ "${ED}"usr/share/wimpiggy/wimpiggy.README || die
+ dodoc {parti.,wimpiggy.,xpra.,}README
+}