summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-05-13 18:00:58 +0000
committerPeter Gavin <pete@gentoo.org>2001-05-13 18:00:58 +0000
commit1972904b6a2fb608f1812d59dda184afc02107c7 (patch)
tree1b08dbfe2e2f2a4c5f00eb9dfafab4d4f5f70749 /x11-wm
parentRemoved, will be integrated in xfree (diff)
downloadgentoo-2-1972904b6a2fb608f1812d59dda184afc02107c7.tar.gz
gentoo-2-1972904b6a2fb608f1812d59dda184afc02107c7.tar.bz2
gentoo-2-1972904b6a2fb608f1812d59dda184afc02107c7.zip
fixed some directory layout issues, and added gdk-pixbuf capability
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce/files/digest-xfce-3.8.1-r11
-rw-r--r--x11-wm/xfce/xfce-3.8.1-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-wm/xfce/files/digest-xfce-3.8.1-r1 b/x11-wm/xfce/files/digest-xfce-3.8.1-r1
new file mode 100644
index 000000000000..51eb1ce0e529
--- /dev/null
+++ b/x11-wm/xfce/files/digest-xfce-3.8.1-r1
@@ -0,0 +1 @@
+MD5 6cc4a90a0d5e45b8f4e3ba06a08981aa xfce-3.8.1.tar.gz
diff --git a/x11-wm/xfce/xfce-3.8.1-r1.ebuild b/x11-wm/xfce/xfce-3.8.1-r1.ebuild
new file mode 100644
index 000000000000..d853c92aa6da
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <ben@sistina.com>
+# /home/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.61.1.ebuild,v 1.1 2001/04/20 18:51:22 drobbins Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="http://prdownloads.sourceforge.net/xfce/${A}"
+HOMEPAGE="http://www.xfce.org/"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2
+ gnome? ( >=gnome-base/gdk-pixbuf-0.10 )"
+
+if [ -z "`use gnome`" ]
+then
+ DEPEND="${DEPEND} >=media-libs/imlib-1.9.10"
+fi
+
+src_compile() {
+ local myconf
+ if [ "`use gnome`" ]
+ then
+ myconf="--enable-imlib=no --enable-gdk-pixbuf=/opt/gnome"
+ fi
+ try ./configure --prefix=/usr/X11R6 --mandir=/usr/X11R6/share/man --host=${CHOST} \
+ --with-data-dir=/usr/X11R6/share/xfce --with-conf-dir=/etc/X11/xfce \
+ --with-locale-dir=/usr/X11R6/share/locale ${myconf}
+ try make
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/xfce
+ mkdir -p /etc/skel/.xfce
+}