summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-06-08 10:41:17 +0000
committerDavid Holm <dholm@gentoo.org>2004-06-08 10:41:17 +0000
commit99cfa702c74dafa969cf216bb5f210ef8d541cbd (patch)
tree6a07e834a714173741cd98afd1aebdd5f4cac746 /x11-wm/waimea
parentinitial commit (Manifest recommit) (diff)
downloadgentoo-2-99cfa702c74dafa969cf216bb5f210ef8d541cbd.tar.gz
gentoo-2-99cfa702c74dafa969cf216bb5f210ef8d541cbd.tar.bz2
gentoo-2-99cfa702c74dafa969cf216bb5f210ef8d541cbd.zip
Added patch from ikezoe (bug #52860)
Diffstat (limited to 'x11-wm/waimea')
-rw-r--r--x11-wm/waimea/ChangeLog7
-rw-r--r--x11-wm/waimea/files/waimea-0.5.0-font.patch11
-rw-r--r--x11-wm/waimea/waimea-0.5.0_pre040506.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/x11-wm/waimea/ChangeLog b/x11-wm/waimea/ChangeLog
index b416eb63fce4..28ad09366a75 100644
--- a/x11-wm/waimea/ChangeLog
+++ b/x11-wm/waimea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/waimea
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/waimea/ChangeLog,v 1.22 2004/06/08 03:03:57 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/waimea/ChangeLog,v 1.23 2004/06/08 10:41:17 dholm Exp $
+
+ 08 Jun 2004; David Holm <dholm@gentoo.org> +files/waimea-0.5.0-font.patch,
+ waimea-0.5.0_pre040506.ebuild:
+ Added patch from ikezoe <ikezoe at users dot sourceforge dot jp> that fixes a
+ crash related to localisation (bug #52860).
07 Jun 2004; Jason Wever <weeve@gentoo.org> waimea-0.4.0-r1.ebuild:
Stable on sparc.
diff --git a/x11-wm/waimea/files/waimea-0.5.0-font.patch b/x11-wm/waimea/files/waimea-0.5.0-font.patch
new file mode 100644
index 000000000000..10c0df49308d
--- /dev/null
+++ b/x11-wm/waimea/files/waimea-0.5.0-font.patch
@@ -0,0 +1,11 @@
+--- waimea-0.5.0_orig/src/Render.cc 2004-04-29 20:17:41.000000000 +0900
++++ waimea-0.5.0/src/Render.cc 2004-06-08 11:56:54.429595664 +0900
+@@ -1589,7 +1589,7 @@
+ font = cairo_current_font(cr);
+ cairo_font_reference (font);
+ }
+-
++ if (!font) return;
+ calc_length(size, size_u, dwo->ws->hdpi, w, &font_size);
+ calc_length(tab_spacing, tab_spacing_u, dwo->ws->hdpi, w, &tab_space);
+ calc_length(line_spacing, line_spacing_u, dwo->ws->vdpi, h, &line_space);
diff --git a/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild b/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild
index ae2addcaca05..020cb979a193 100644
--- a/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild
+++ b/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild,v 1.5 2004/06/05 19:49:05 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild,v 1.6 2004/06/08 10:41:17 dholm Exp $
inherit eutils 64-bit
@@ -27,6 +27,7 @@ src_unpack() {
unpack ${A}
cd ${S}
64-bit && epatch ${FILESDIR}/${MY_P}-64bit-clean.patch
+ epatch ${FILESDIR}/${MY_P}-font.patch
}
src_compile() {