summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-20 19:33:36 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-20 19:33:36 +0000
commitcaf40ce69511429c87c9ac81c271b496bac9aa5e (patch)
treec3170d027697470cf4e9ea6ef94af7200f9a93e1 /x11-wm/subtle
parentsci-libs/cminpack: Version BUmp, add underlinking fix, which fixes test failu... (diff)
downloadgentoo-2-caf40ce69511429c87c9ac81c271b496bac9aa5e.tar.gz
gentoo-2-caf40ce69511429c87c9ac81c271b496bac9aa5e.tar.bz2
gentoo-2-caf40ce69511429c87c9ac81c271b496bac9aa5e.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/subtle')
-rw-r--r--x11-wm/subtle/ChangeLog10
-rw-r--r--x11-wm/subtle/files/subtle-0.11.3224-flags.patch23
-rw-r--r--x11-wm/subtle/subtle-0.11.3224.ebuild80
3 files changed, 111 insertions, 2 deletions
diff --git a/x11-wm/subtle/ChangeLog b/x11-wm/subtle/ChangeLog
index 72116864a299..7fe1f822ea19 100644
--- a/x11-wm/subtle/ChangeLog
+++ b/x11-wm/subtle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/subtle
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/ChangeLog,v 1.3 2011/10/29 05:38:09 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/ChangeLog,v 1.4 2012/06/20 19:33:35 radhermit Exp $
+
+*subtle-0.11.3224 (20 Jun 2012)
+
+ 20 Jun 2012; Tim Harder <radhermit@gentoo.org> +subtle-0.11.3224.ebuild,
+ +files/subtle-0.11.3224-flags.patch:
+ Version bump.
29 Oct 2011; Tim Harder <radhermit@gentoo.org> subtle-0.10.3008.ebuild,
subtle-9999.ebuild:
diff --git a/x11-wm/subtle/files/subtle-0.11.3224-flags.patch b/x11-wm/subtle/files/subtle-0.11.3224-flags.patch
new file mode 100644
index 000000000000..c8fb6554d90e
--- /dev/null
+++ b/x11-wm/subtle/files/subtle-0.11.3224-flags.patch
@@ -0,0 +1,23 @@
+--- subtle-0.11.3224-xi/Rakefile
++++ subtle-0.11.3224-xi/Rakefile
+@@ -63,9 +63,9 @@
+ "hdrdir" => "",
+ "archdir" => "",
+ "revision" => "3224", #< Latest stable
+- "cflags" => "-Wall -Werror -Wpointer-arith -Wstrict-prototypes -Wunused -Wshadow -std=gnu99",
++ "cflags" => "$(CFLAGS) -Wall -Wpointer-arith -Wstrict-prototypes -Wunused -Wshadow -std=gnu99",
+ "cpppath" => "-I. -I$(builddir) -Isrc -Isrc/shared -Isrc/subtle -idirafter$(hdrdir) -idirafter$(archdir)",
+- "ldflags" => "-L$(libdir) $(rpath) $(LIBS) -l$(RUBY_SO_NAME)",
++ "ldflags" => "$(LDFLAGS) -L$(libdir) $(rpath) $(LIBS) -l$(RUBY_SO_NAME)",
+ "extflags" => "$(LDFLAGS) $(rpath) $(LIBS) -l$(RUBY_SO_NAME)",
+ "rpath" => "-L$(libdir) -Wl,-rpath=$(libdir)",
+ "checksums" => []
+@@ -276,7 +276,7 @@
+
+ # Debug
+ if "yes" == @options["debug"]
+- @options["cflags"] << " -g -DDEBUG"
++ @options["cflags"] << " -DDEBUG"
+ else
+ @options["cflags"] << " -DNDEBUG"
+ end
diff --git a/x11-wm/subtle/subtle-0.11.3224.ebuild b/x11-wm/subtle/subtle-0.11.3224.ebuild
new file mode 100644
index 000000000000..2c6b7daba0e0
--- /dev/null
+++ b/x11-wm/subtle/subtle-0.11.3224.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/subtle-0.11.3224.ebuild,v 1.1 2012/06/20 19:33:35 radhermit Exp $
+
+EAPI="4"
+USE_RUBY="ruby19"
+
+inherit ruby-ng toolchain-funcs
+
+GR="xi"
+
+DESCRIPTION="A manual tiling window manager"
+HOMEPAGE="http://subforge.org/projects/subtle/wiki"
+SRC_URI="http://subforge.org/attachments/download/81/${P}-${GR}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc +xft xinerama xpm +xrandr +xtest"
+
+RDEPEND="x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ xtest? ( x11-libs/libXtst )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+ruby_add_rdepend "dev-ruby/archive-tar-minitar"
+ruby_add_bdepend "dev-ruby/rake"
+
+RUBY_S="${P}-${GR}"
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+each_ruby_configure() {
+ local myconf
+ use debug && myconf+=" debug=yes" || myconf+=" debug=no"
+ use xft && myconf+=" xft=yes" || myconf+=" xft=no"
+ use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
+ use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
+ use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
+ use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
+
+ ${RUBY} -S rake -v CC="$(tc-getCC)" destdir="${D}" ${myconf} config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake -v build || die
+}
+
+all_ruby_compile() {
+ use doc && { rake rdoc || die ; }
+}
+
+each_ruby_install() {
+ ${RUBY} -S rake -v install || die
+}
+
+all_ruby_install() {
+ dodir /etc/X11/Sessions
+ cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
+ #!/bin/sh
+ exec /usr/bin/subtle
+ EOF
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins data/${PN}.desktop
+
+ dodoc AUTHORS NEWS
+
+ use doc && dohtml -r html/*
+}
+
+pkg_postinst() {
+ elog "Note that surserver will currently not work since dev-ruby/datamapper"
+ elog "is not in the tree."
+}