summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-05-21 20:31:09 +0000
committerCédric Krier <cedk@gentoo.org>2007-05-21 20:31:09 +0000
commit67994ebf784d5726689cbc99e0894523a8fef3ce (patch)
tree48ea304f164a001f25a2b1c82b7741c72c82248b /x11-wm/dwm
parentInitial import of ebuild. (diff)
downloadgentoo-2-67994ebf784d5726689cbc99e0894523a8fef3ce.tar.gz
gentoo-2-67994ebf784d5726689cbc99e0894523a8fef3ce.tar.bz2
gentoo-2-67994ebf784d5726689cbc99e0894523a8fef3ce.zip
x11-wm/dwm: Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'x11-wm/dwm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-4.1.ebuild66
-rw-r--r--x11-wm/dwm/files/digest-dwm-4.13
3 files changed, 75 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index c14a91444f89..0ced5b609afd 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.18 2007/04/20 18:39:49 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.19 2007/05/21 20:31:09 cedk Exp $
+
+*dwm-4.1 (21 May 2007)
+
+ 21 May 2007; Cédric Krier <cedk@gentoo.org> +dwm-4.1.ebuild:
+ Version bump
*dwm-4.0 (20 Apr 2007)
diff --git a/x11-wm/dwm/dwm-4.1.ebuild b/x11-wm/dwm/dwm-4.1.ebuild
new file mode 100644
index 000000000000..6c7698e0b815
--- /dev/null
+++ b/x11-wm/dwm/dwm-4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-4.1.ebuild,v 1.1 2007/05/21 20:31:09 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://dwm.suckless.org/"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS += -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}
diff --git a/x11-wm/dwm/files/digest-dwm-4.1 b/x11-wm/dwm/files/digest-dwm-4.1
new file mode 100644
index 000000000000..2572222d3ece
--- /dev/null
+++ b/x11-wm/dwm/files/digest-dwm-4.1
@@ -0,0 +1,3 @@
+MD5 12b62b38e34e6666e6a9617747a0ed70 dwm-4.1.tar.gz 19209
+RMD160 3d7d49590593675473d2157b8eb4c2f11d8eab18 dwm-4.1.tar.gz 19209
+SHA256 8f92a9b1adaeac8b0d9f161a427548bad5867a87bdd6555fc3d5a93178f7a036 dwm-4.1.tar.gz 19209