summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-14 07:39:53 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-14 07:39:53 +0000
commite8e9dcdd0d93af5379fd81aff0723482f0f876c5 (patch)
treeaeb5be18c76f47461edcc2ae2f02fbbf14e33777 /x11-wm/afterstep
parenthandle GNUstep env settings (diff)
downloadgentoo-2-e8e9dcdd0d93af5379fd81aff0723482f0f876c5.tar.gz
gentoo-2-e8e9dcdd0d93af5379fd81aff0723482f0f876c5.tar.bz2
gentoo-2-e8e9dcdd0d93af5379fd81aff0723482f0f876c5.zip
AfterStep to /usr, other small fixes and added some files that i missed
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/afterstep-1.8.10.ebuild50
-rw-r--r--x11-wm/afterstep/afterstep-1.8.8.ebuild66
-rwxr-xr-xx11-wm/afterstep/files/afterstep3
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-1.8.101
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-1.8.81
5 files changed, 51 insertions, 70 deletions
diff --git a/x11-wm/afterstep/afterstep-1.8.10.ebuild b/x11-wm/afterstep/afterstep-1.8.10.ebuild
new file mode 100644
index 000000000000..5de8ed29104d
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-1.8.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pete@gentoo.org>
+
+S=${WORKDIR}/AfterStep-${PV}
+DESCRIPTION="A window manager based on the NeXTStep interface."
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
+HOMEPAGE="http://www.afterstep.org/"
+
+DEPEND="virtual/glibc virtual/x11
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.5
+ x11-wm/gnustep-env"
+
+RDEPEND="virtual/glibc virtual/x11
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.5
+ >=media-sound/sox-12.17.1
+ x11-wm/gnustep-env"
+
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/X11 \
+ --with-helpcommand="xterm -e man" \
+ --disable-availability \
+ --disable-staticlibs || die
+
+ make || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
+ install || die
+
+ rm -f ${D}/usr/bin/sessreg
+
+ dodoc COPYRIGHT ChangeLog INSTALL NEW README* TEAM UPGRADE
+ cp -a ${S}/TODO ${D}/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -a ${S}/doc/* ${D}/usr/share/doc/${PF}/html
+ rm ${D}/usr/share/doc/${PF}/html/Makefile*
+}
diff --git a/x11-wm/afterstep/afterstep-1.8.8.ebuild b/x11-wm/afterstep/afterstep-1.8.8.ebuild
deleted file mode 100644
index 681974b6d5b2..000000000000
--- a/x11-wm/afterstep/afterstep-1.8.8.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-1.8.8.ebuild,v 1.4 2001/08/11 05:32:14 drobbins Exp $
-
-#P=
-A=AfterStep-${PV}.tar.bz2
-S=${WORKDIR}/AfterStep-${PV}
-DESCRIPTION="a window manager based on the NeXTStep interface"
-SRC_URI="ftp://ftp.afterstep.org/stable/${A}"
-HOMEPAGE="http://www.afterstep.org/"
-
-DEPEND="virtual/glibc virtual/x11
- >=media-libs/jpeg-6b
- >=media-libs/libpng-1.0.5"
-
-RDEPEND="virtual/glibc virtual/x11
- >=media-libs/jpeg-6b
- >=media-libs/libpng-1.0.5
- >=media-sound/sox-12.17.1"
-
-
-src_compile() {
- try ./configure --prefix=/usr/X11R6 --host=${CHOST} \
- --with-helpcommand="xterm -e man" \
- --disable-availability \
- --disable-staticlibs
- try make
-}
-
-src_install () {
- try make DESTDIR=${D} install
- rm -f ${D}/usr/X11R6/bin/sessreg
-
- exeinto /usr/X11R6/bin/wm
- doexe ${FILESDIR}/afterstep
-
- dodoc COPYRIGHT ChangeLog NEW README README.HPUX
- dodoc README.RedHat README.SOLARIS TEAM UPGRADE
-
- cd ${S}/TODO ; docinto TODO
- dodoc BUGLIST.1st BUGLIST.l8r TODO-WinList active.desk.gz
- dodoc autoconf.patch.gz classic.afterstep.gz classic.wharf.gz
- dodoc fvwm.startondeskNpage.patch.gz gnome.html.gz
-
- cd ${S}/TODO/1.0_to_1.5 ; docinto TODO/1.0_to_1.5
- dodoc look.script step2files.pl whatsnew
-
- cd ${S}/TODO/unreleased ; docinto TODO/unreleased
- dodoc AfterStep-1.5beta3-stack-tabbing.diff.gz
- dodoc beta3-stack-tabiing.patch.gz
-
- cd ${S}/TODO/unstable ; docinto TODO/unstable
- dodoc as-icon+title.patch.gz as-icon+title.readme
-
- cd ${S}/doc/code ; docinto code
- dodoc Error_codes Optimizing Patch asetroot.format config_issues.html parser_devel_guide.html
-
- cd ${S}/doc/languages ; docinto languages
- dodoc README.cz README.de README.dk README.es README.fi README.fr
- dodoc README.gr README.id README.it README.jp README.nl README.no
- dodoc README.pl README.ro README.ru.koi8 README.se README.tw README.yu
-
- cd ${S}/doc/licences ; docinto licences
- dodoc COPYING COPYING.LDP COPYING.LIB
-}
diff --git a/x11-wm/afterstep/files/afterstep b/x11-wm/afterstep/files/afterstep
deleted file mode 100755
index d903fedd32a5..000000000000
--- a/x11-wm/afterstep/files/afterstep
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-exec /usr/X11R6/bin/afterstep
diff --git a/x11-wm/afterstep/files/digest-afterstep-1.8.10 b/x11-wm/afterstep/files/digest-afterstep-1.8.10
new file mode 100644
index 000000000000..d7c7f5ac0d8d
--- /dev/null
+++ b/x11-wm/afterstep/files/digest-afterstep-1.8.10
@@ -0,0 +1 @@
+MD5 2743d479ecdf16c27111ddb664d2be91 AfterStep-1.8.10.tar.bz2
diff --git a/x11-wm/afterstep/files/digest-afterstep-1.8.8 b/x11-wm/afterstep/files/digest-afterstep-1.8.8
deleted file mode 100644
index ac4c14230e74..000000000000
--- a/x11-wm/afterstep/files/digest-afterstep-1.8.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ce5e49fe20e59551c4fe9ec7f834bb90 AfterStep-1.8.8.tar.bz2