summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-12-28 19:25:55 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-12-28 19:25:55 +0000
commit706a5eea6d05884e96be58c7104983f244223c1a (patch)
tree4d4755bc62d2ab768087082618ad784c7a1fd81a /x11-themes
parentold (diff)
downloadgentoo-2-706a5eea6d05884e96be58c7104983f244223c1a.tar.gz
gentoo-2-706a5eea6d05884e96be58c7104983f244223c1a.tar.bz2
gentoo-2-706a5eea6d05884e96be58c7104983f244223c1a.zip
fix autotools handling (bug #150280) and minor stylistic changes
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-mist/ChangeLog7
-rw-r--r--x11-themes/gtk-engines-mist/gtk-engines-mist-0.10-r2.ebuild21
2 files changed, 16 insertions, 12 deletions
diff --git a/x11-themes/gtk-engines-mist/ChangeLog b/x11-themes/gtk-engines-mist/ChangeLog
index 9f618b4f47d1..fcdb7d6231f5 100644
--- a/x11-themes/gtk-engines-mist/ChangeLog
+++ b/x11-themes/gtk-engines-mist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/gtk-engines-mist
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-mist/ChangeLog,v 1.20 2006/02/02 17:18:30 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-mist/ChangeLog,v 1.21 2006/12/28 19:25:55 compnerd Exp $
+
+ 28 Dec 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ gtk-engines-mist-0.10-r2.ebuild:
+ Fix autotools handling with patch from jakub <jakub@gentoo.org> and minor
+ stylistic changes
02 Feb 2006; Simon Stelling <blubb@gentoo.org>
gtk-engines-mist-0.10-r2.ebuild:
diff --git a/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10-r2.ebuild b/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10-r2.ebuild
index 7b045f1108de..5c16e9cc38ba 100644
--- a/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10-r2.ebuild
+++ b/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10-r2.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10-r2.ebuild,v 1.9 2006/02/02 17:18:30 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10-r2.ebuild,v 1.10 2006/12/28 19:25:55 compnerd Exp $
-inherit eutils
+WANT_AUTOMAKE="1.6"
+WANT_AUTOCONF="latest"
+
+inherit autotools eutils
MY_PN="gtk-mist-engine"
MY_P=${MY_PN}-${PV}
@@ -10,14 +13,16 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="GTK+1 Mist Theme Engine"
HOMEPAGE="http://primates.ximian.com/~dave/mist/"
SRC_URI="http://primates.ximian.com/~dave/mist/${MY_P}.tar.gz"
-KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
+
LICENSE="GPL-2"
SLOT="1"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
IUSE="static"
DEPEND="=x11-libs/gtk+-1.2*"
+RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
@@ -25,12 +30,7 @@ src_unpack() {
# patch that adds --[enable|disable]-gtk-[1|2] - liquidx@g.o (04 Oct 03)
epatch ${FILESDIR}/${P}-autoconf.patch
-
- export WANT_AUTOMAKE=1.6
- aclocal || die "aclocal failed"
- autoconf || die "autoconf failed"
- automake || die "automake failed"
- libtoolize --copy --force
+ eautoreconf
}
src_compile() {
@@ -42,6 +42,5 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "Installation failed"
-
dodoc AUTHORS ChangeLog NEWS README TODO
}