summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-18 02:16:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-18 02:16:22 +0000
commit65cd592cfaef31533198ea8ab9d5034e617bf858 (patch)
tree3b204145023f1fa02d1c82f933bf93fa5f6e328e /x11-themes
parentEnable __cxa_atexit for FreeBSD too, as that's needed for proper C++ librarie... (diff)
downloadgentoo-2-65cd592cfaef31533198ea8ab9d5034e617bf858.tar.gz
gentoo-2-65cd592cfaef31533198ea8ab9d5034e617bf858.tar.bz2
gentoo-2-65cd592cfaef31533198ea8ab9d5034e617bf858.zip
Add a patch to build on FreeBSD, and add ~x86-fbsd keyword. Note that this package requires a GCC compiled with the latest change to toolchain.eclass to enable __cxa_atexit.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/domino/ChangeLog8
-rw-r--r--x11-themes/domino/domino-0.4.ebuild11
-rw-r--r--x11-themes/domino/files/domino-0.4-fbsd.patch55
3 files changed, 71 insertions, 3 deletions
diff --git a/x11-themes/domino/ChangeLog b/x11-themes/domino/ChangeLog
index 6ee98349d6b8..248bd8828ebe 100644
--- a/x11-themes/domino/ChangeLog
+++ b/x11-themes/domino/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/domino
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/domino/ChangeLog,v 1.2 2007/02/17 00:45:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/domino/ChangeLog,v 1.3 2007/02/18 02:16:22 flameeyes Exp $
+
+ 18 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/domino-0.4-fbsd.patch, domino-0.4.ebuild:
+ Add a patch to build on FreeBSD, and add ~x86-fbsd keyword. Note that this
+ package requires a GCC compiled with the latest change to toolchain.eclass
+ to enable __cxa_atexit.
16 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> domino-0.4.ebuild:
Add dependency over kwin/kdebase for the windows decoration.
diff --git a/x11-themes/domino/domino-0.4.ebuild b/x11-themes/domino/domino-0.4.ebuild
index 58aa3fb03491..6f6af7ba4160 100644
--- a/x11-themes/domino/domino-0.4.ebuild
+++ b/x11-themes/domino/domino-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/domino/domino-0.4.ebuild,v 1.2 2007/02/17 00:45:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/domino/domino-0.4.ebuild,v 1.3 2007/02/18 02:16:22 flameeyes Exp $
ARTS_REQUIRED="never"
inherit kde
@@ -11,8 +11,15 @@ SRC_URI="http://www.kde-look.org/CONTENT/content-files/42804-${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86-fbsd"
IUSE=""
RDEPEND="|| ( kde-base/kwin kde-base/kdebase )"
need-kde 3.4
+
+PATCHES="${FILESDIR}/${P}-fbsd.patch"
+
+src_unpack() {
+ kde_src_unpack
+ rm -f "${S}/configure"
+}
diff --git a/x11-themes/domino/files/domino-0.4-fbsd.patch b/x11-themes/domino/files/domino-0.4-fbsd.patch
new file mode 100644
index 000000000000..6e2b21ac89c0
--- /dev/null
+++ b/x11-themes/domino/files/domino-0.4-fbsd.patch
@@ -0,0 +1,55 @@
+Fix building on FreeBSD systems.
+Index: domino-0.4/configure.in.in
+===================================================================
+--- domino-0.4.orig/configure.in.in
++++ domino-0.4/configure.in.in
+@@ -1 +1,3 @@
+ #MIN_CONFIG
++
++AC_CHECK_HEADERS([endian.h sys/endian.h])
+Index: domino-0.4/domino/misc.cpp
+===================================================================
+--- domino-0.4.orig/domino/misc.cpp
++++ domino-0.4/domino/misc.cpp
+@@ -22,19 +22,30 @@
+ #include "misc.h"
+ #include <qimage.h>
+ #include <qpixmap.h>
+-#include <endian.h>
+-
+-#if __BYTE_ORDER == __LITTLE_ENDIAN
+-#undef WORDS_BIGENDIAN
+-#define WORDS_LITTLEENDIAN 1
+-#endif
+-#if __BYTE_ORDER == __BIG_ENDIAN
+- #undef WORDS_LITTLEENDIAN
+- #define WORDS_BIGENDIAN 1
+-#endif
+-
+
++#include <config.h>
+
++#ifdef HAVE_ENDIAN_H
++# include <endian.h>
++# if __BYTE_ORDER == __LITTLE_ENDIAN
++# undef WORDS_BIGENDIAN
++# define WORDS_LITTLEENDIAN 1
++# endif
++# if __BYTE_ORDER == __BIG_ENDIAN
++# undef WORDS_LITTLEENDIAN
++# define WORDS_BIGENDIAN 1
++# endif
++#elif HAVE_SYS_ENDIAN_H /* *BSD in general */
++# include <sys/endian.h>
++# if _BYTE_ORDER == _LITTLE_ENDIAN
++# undef WORDS_BIGENDIAN
++# define WORDS_LITTLEENDIAN 1
++# endif
++# if _BYTE_ORDER == _BIG_ENDIAN
++# undef WORDS_LITTLEENDIAN
++# define WORDS_BIGENDIAN 1
++# endif
++#endif
+
+ QColor alphaBlendColors(const QColor &bgColor, const QColor &fgColor, const int a)
+ {