summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-06-03 10:27:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-06-03 10:27:25 +0000
commit11940b68403ead454c9d349254023aa9b60832cd (patch)
tree7de2781ccf36ad951916f3f7e57ff9070dfcb842 /x11-themes
parentVersion bump (diff)
downloadgentoo-2-11940b68403ead454c9d349254023aa9b60832cd.tar.gz
gentoo-2-11940b68403ead454c9d349254023aa9b60832cd.tar.bz2
gentoo-2-11940b68403ead454c9d349254023aa9b60832cd.zip
Version bump. Punt some bogus directories as /usr/share/icons is meant for complete icon themes with index.theme file.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/faenza-icon-theme/ChangeLog11
-rw-r--r--x11-themes/faenza-icon-theme/faenza-icon-theme-1.3.1.ebuild51
2 files changed, 60 insertions, 2 deletions
diff --git a/x11-themes/faenza-icon-theme/ChangeLog b/x11-themes/faenza-icon-theme/ChangeLog
index 82955bb6da2a..f8160756ff44 100644
--- a/x11-themes/faenza-icon-theme/ChangeLog
+++ b/x11-themes/faenza-icon-theme/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/faenza-icon-theme
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/faenza-icon-theme/ChangeLog,v 1.21 2013/12/25 09:36:08 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/faenza-icon-theme/ChangeLog,v 1.22 2014/06/03 10:27:25 ssuominen Exp $
+
+*faenza-icon-theme-1.3.1 (03 Jun 2014)
+
+ 03 Jun 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +faenza-icon-theme-1.3.1.ebuild:
+ Version bump. Punt some bogus directories as /usr/share/icons is meant for
+ complete icon themes with index.theme file.
25 Dec 2013; Markus Meier <maekke@gentoo.org> faenza-icon-theme-1.3.ebuild:
add ~arm, bug #488582
diff --git a/x11-themes/faenza-icon-theme/faenza-icon-theme-1.3.1.ebuild b/x11-themes/faenza-icon-theme/faenza-icon-theme-1.3.1.ebuild
new file mode 100644
index 000000000000..2c235756cd52
--- /dev/null
+++ b/x11-themes/faenza-icon-theme/faenza-icon-theme-1.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/faenza-icon-theme/faenza-icon-theme-1.3.1.ebuild,v 1.1 2014/06/03 10:27:25 ssuominen Exp $
+
+EAPI=5
+inherit gnome2-utils
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="A scalable icon theme called Faenza"
+HOMEPAGE="http://tiheum.deviantart.com/art/Faenza-Icons-173323228"
+# Use Ubuntu repo which has a proper faenza-icon-theme tarball
+#SRC_URI="http://faenza-icon-theme.googlecode.com/files/${PN}_${PV}.tar.gz"
+SRC_URI="http://ppa.launchpad.net/tiheum/equinox/ubuntu/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+RESTRICT="binchecks strip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( x11-themes/gnome-icon-theme )
+ x11-themes/hicolor-icon-theme"
+
+S=${WORKDIR}/${PN}-${PV%.*}
+
+src_prepare() {
+ local res x
+ for x in Faenza Faenza-Dark; do
+ for res in 22 24 32 48 64 96; do
+ cp "${x}"/places/${res}/start-here-gentoo.png \
+ "${x}"/places/${res}/start-here.png || die
+ done
+ cp "${x}"/places/scalable/start-here-gentoo.svg \
+ "${x}"/places/scalable/start-here.svg || die
+ done
+}
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r Faenza{,-Ambiance,-Dark,-Darker,-Darkest,-Radiance}
+
+ # TODO: Install to directories where the apps can find them
+ # insinto ${somewhere}
+ # doins -r emesene dockmanager rhythmbox
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }